cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1529
Views
1
Helpful
4
Replies

Static Routing Won't Save

putra.research
Level 1
Level 1

I'm trying to make Static Routing in 3 routers. But 1 routers always won't save the static routing setting. Is there any solution?

Cannot Save.JPG

Can Save.JPG

  

2 Accepted Solutions

Accepted Solutions

Hello
You had incorrect ip address assignment on your router interfaces and incorrect static routes.
Suggest as you have multiple egress paths on the rtrs not to use static routing as this would be to much of an administrative burden to manage and instead use an igp such as rip/eigrp/ospf.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

Hello,

 the static route is not saved because the next hop is not on the same subnet. You need to change the IP addressing on RouterA (and RouterB) as below (revised file attached):

 

RouterA#sh run
Building configuration...

Current configuration : 661 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RouterA
!
ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 192.168.1.1 255.255.255.252
!
interface GigabitEthernet8/0
ip address 192.168.1.6 255.255.255.252
!
interface FastEthernet9/0
ip address 172.17.1.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 10.20.30.0 255.255.255.0 192.168.1.2
ip route 192.168.100.0 255.255.255.0 192.168.1.14
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

RouterB#sh run
Building configuration...

Current configuration : 674 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RouterB
!
ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 192.168.1.9 255.255.255.252
!
interface GigabitEthernet8/0
ip address 192.168.1.2 255.255.255.252
!
interface FastEthernet9/0
ip address 10.20.30.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 172.17.1.0 255.255.255.0 192.168.1.1
ip route 192.168.100.0 255.255.255.0 192.168.1.10
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




RouterC#sh run
Building configuration...

Current configuration : 658 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RouterC
!
ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 192.168.1.5 255.255.255.252
!
interface GigabitEthernet8/0
ip address 192.168.1.10 255.255.255.252
!
interface FastEthernet9/0
ip address 40.50.60.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 172.17.1.0 255.255.255.0 192.168.1.6
ip route 10.20.30.0 255.255.255.0 192.168.1.9
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

View solution in original post

4 Replies 4

Hello
You had incorrect ip address assignment on your router interfaces and incorrect static routes.
Suggest as you have multiple egress paths on the rtrs not to use static routing as this would be to much of an administrative burden to manage and instead use an igp such as rip/eigrp/ospf.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thank you so much for your suggestion. Aprreciate it

Hello,

 the static route is not saved because the next hop is not on the same subnet. You need to change the IP addressing on RouterA (and RouterB) as below (revised file attached):

 

RouterA#sh run
Building configuration...

Current configuration : 661 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RouterA
!
ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 192.168.1.1 255.255.255.252
!
interface GigabitEthernet8/0
ip address 192.168.1.6 255.255.255.252
!
interface FastEthernet9/0
ip address 172.17.1.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 10.20.30.0 255.255.255.0 192.168.1.2
ip route 192.168.100.0 255.255.255.0 192.168.1.14
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

RouterB#sh run
Building configuration...

Current configuration : 674 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RouterB
!
ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 192.168.1.9 255.255.255.252
!
interface GigabitEthernet8/0
ip address 192.168.1.2 255.255.255.252
!
interface FastEthernet9/0
ip address 10.20.30.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 172.17.1.0 255.255.255.0 192.168.1.1
ip route 192.168.100.0 255.255.255.0 192.168.1.10
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end




RouterC#sh run
Building configuration...

Current configuration : 658 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname RouterC
!
ip cef
no ipv6 cef
!
interface GigabitEthernet7/0
ip address 192.168.1.5 255.255.255.252
!
interface GigabitEthernet8/0
ip address 192.168.1.10 255.255.255.252
!
interface FastEthernet9/0
ip address 40.50.60.1 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 172.17.1.0 255.255.255.0 192.168.1.6
ip route 10.20.30.0 255.255.255.0 192.168.1.9
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Thankyou so much, it's work!

Review Cisco Networking for a $25 gift card