01-28-2013 05:27 AM - edited 03-04-2019 06:51 PM
Hello there,
I am trying simulate a simple VPN network. Find below, the contents of one of the vrf tables. My challenge here is that I am unable to redistribute the BGP routes in the VPN table back into the CE's routing table. Command such as:
PE1(config-router)# redistribute bgp xxx route-map yyy has not had any effect. Please, give advice on how to implement this. Thanks.
*************************************************************************************************************
PE1#show ip bgp vpnv4 vrf orange
!
!
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10000:10 (default for vrf orange)
*>i10.0.0.4/32 10.0.0.2 156160 100 0 ?
*> 10.0.0.6/32 10.255.1.2 156160 32768 ?
*> 10.255.1.0/30 0.0.0.0 0 32768 ?
*> 10.255.2.0/24 10.255.1.2 30720 32768 ?
*>i10.255.3.0/30 10.0.0.2 0 100 0 ?
*>i10.255.4.0/24 10.0.0.2 30720 100 0 ?
!
PE1#
**********************************************************************************************************
PE1#show ip route vrf orange
!
!
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D 10.0.0.6/32 [90/156160] via 10.255.1.2, 00:15:12, FastEthernet0/1
B 10.0.0.4/32 [200/156160] via 10.0.0.2, 00:14:20
B 10.255.4.0/24 [200/30720] via 10.0.0.2, 00:14:20
C 10.255.1.0/30 is directly connected, FastEthernet0/1
B 10.255.3.0/30 [200/0] via 10.0.0.2, 00:14:20
D 10.255.2.0/24 [90/30720] via 10.255.1.2, 00:15:12,
!
PE1#
Solved! Go to Solution.
01-29-2013 06:22 AM
hi
"PE1(config-router)# redistribute bgp xxx route-map yyy has not had any effect"
Did you use this command under eigrp address family? Because from config-router it looks like you did not. Also add metric statement.
So try:
router eigrp 10000
address-family ipv4 vrf orange
redistribute bgp 50000 metric 1500 100 255 1 1500
01-28-2013 05:52 AM
Hello Jaighobahi,
it looks like your PE-CE protocol is EIGRP.
EIGRP requires the setting of a seed metric in order to successfully redistribute routes into EIGRP.
EIGRP seed metric requires to specify the values of the components of EIGRP metric calculation: bandwidth delay reliability load mtu with default-metric command
so under
router eigrp
add something like:
default-metric 1000 1000 255 1 1500
see
http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094613.shtml#rdc
and command reference
Hope to help
Giuseppe
01-28-2013 08:22 AM
Thanks. I have tried to include the seed metric but it still doesn't have any effect.
01-29-2013 12:55 AM
Hello Jaighobahi,
in order to get better help please post the relevant parts of PE configuration.
Hope to help
Giuseppe
01-29-2013 02:40 AM
Here is the configuration of one of the two PEs. The network arrangement is also attached.
PE1#show run
!
ip cef
!
!
ip vrf apple
rd 20000:172
route-target export 20000:172
route-target import 20000:172
!
!
ip vrf orange
rd 10000:10
route-target export 10000:10
route-target import 10000:10
!
!
interface Loopback0
ip address 10.0.0.7 255.255.255.255
!
!
interface FastEthernet0/0
ip vrf forwarding apple
ip address 172.16.1.1 255.255.255.252
speed 100
full-duplex
!
!
interface Serial0/0
bandwidth 256
ip address 192.168.1.2 255.255.255.252
mpls ip
clock rate 2000000
!
!
interface FastEthernet0/1
ip vrf forwarding orange
ip address 10.255.1.1 255.255.255.252
speed 100
full-duplex
!
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
!
router eigrp 10000
network 10.255.1.0 0.0.0.3
no auto-summary
!
!
address-family ipv4 vrf orange
network 10.255.1.0 0.0.0.3
no auto-summary
autonomous-system 10000
exit-address-family
!
!
router eigrp 20000
network 172.16.1.0 0.0.0.3
no auto-summary
!
!
address-family ipv4 vrf apple
network 172.16.1.0 0.0.0.3
no auto-summary
autonomous-system 20000
exit-address-family
!
!
router eigrp 40000
network 10.0.0.7 0.0.0.0
network 192.168.1.0 0.0.0.3
no auto-summary
!
!
router bgp 50000
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.2 remote-as 50000
neighbor 10.0.0.2 update-source Loopback0
no auto-summary
!
!
address-family vpnv4
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 send-community extended
exit-address-family
!
!
address-family ipv4 vrf orange
redistribute eigrp 10000
no synchronization
exit-address-family
!
!
address-family ipv4 vrf apple
redistribute eigrp 20000
no synchronization
exit-address-family
!
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
PE1#
01-29-2013 06:22 AM
hi
"PE1(config-router)# redistribute bgp xxx route-map yyy has not had any effect"
Did you use this command under eigrp address family? Because from config-router it looks like you did not. Also add metric statement.
So try:
router eigrp 10000
address-family ipv4 vrf orange
redistribute bgp 50000 metric 1500 100 255 1 1500
01-29-2013 11:26 PM
Thanks you very much. I was issuing the command "PE1(config-router)# redistribute bgp xxx route-map yyy " under eigrp 10000 process rather than under "address-family ipv4 vrf orange". You did not see it in the scripts above becasue I removed it when it was not working. The network is working as expected having followed your advice. Much appreciation to everyone who has taken time to look at the problem. But eh, can anyone explain the difference between the following?
address-family ipv4 vrf
address-family vpnv4
Apology, they are somewhat fuzzy!
01-30-2013 12:20 AM
address-family ipv4 vrf
- is used on PE toward CE router to configure PE-CE exchange of IPv4 prefixes.
address-family vpnv4
- is used on routers, iBGP peers, to configure exchange of vpn4 prefixes (rd+ipv4)
01-30-2013 02:58 AM
I see now there is a reference to RD. Based on the scripts I inserted above,at what point do the statements route-target export
Thanks
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide