cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
239
Views
0
Helpful
8
Replies
Beginner

sub interface vlan issue

I use a Cisco 9000 router I have a issue with a client, everything works fine. I have a 10G interface, we have created two sub-interfaces (VLAN2 and VLAN 3) the ping test works well and we use a loopback interface for the session bgp my issue is that the bgp session works with the vlan 2 but not with vlan 3 when I remove the route IP vlan 2 the session bgp switches to vlan3. i want the bgp session to work on both vlan 2 & 3 at the same time and if a vlan goes down automatically the other vlan must take the hand.

 

Int TenGigE0 / 6/3 / 0.2
Address IPv4 192.168.1.225 255.255.255.252
dot1q vlan 2
!

Int TenGigE0 / 6/3 / 0.3
Address IPv4 192.168.1.230 255.255.255.252
dot1q vlan 3
!


197.16.12.249/32 192.168.1.226
197.16.12.249/32 196.168.1.230 

 

Anyone have any ideas? Thanks for your time,

 

Abdoulka

8 REPLIES 8
VIP Mentor

Re: sub interface vlan issue

Hello,

 

if you peer with loopback addresses, the loopback address must be reachable through both Vlans. Post a schematic drawing of your topology, as it is unclear from your brief description how your network is configured...

Beginner

Re: sub interface vlan issue

Hi,

the loopback address is reachable through both Vlans.

 

197.16.12.249/32 192.168.1.226
197.16.12.249/32 196.168.1.230

 

i wanna the loopback addresses communicate with both vlans at the same time

Everyone's tags (1)
VIP Advisor

Re: sub interface vlan issue

AS suggested we need to more information of the config to look and see what is wrong

 

On high level, if this is routing table ?

 

197.16.12.249/32 192.168.1.226 
197.16.12.249/32 196.168.1.230    <<- is this belowing to other side loopback - the route should be point to other router, its pointing to local interface.

 

this is my assumption  ? but we can only confirm seeing your config,

BB
*** Rate All Helpful Responses ***
Beginner

Re: sub interface vlan issue

The ip of the loopback interface that I use is the client that propagated me it's his address to him.

 

Int TenGigE0 / 6/3 / 0.2 
Address IPv4 192.168.1.225 255.255.255.252 
dot1q vlan 2 
!

Int TenGigE0 / 6/3 / 0.3 
Address IPv4 192.168.1.230 255.255.255.252 
dot1q vlan 3 
!


ip route 197.16.12.249/32 192.168.1.226 
ip route 197.16.12.249/32 196.168.1.230 

 

This is my BGP config : 

 

router bgp XXX
neighbor 197.16.12.249
remote-as YYY
ebgp-multihop 2
timers 2 3
password encrypted 02350B561F0303010F6A235D40
description Customer1
update-source Loopback0
address-family ipv4 unicast
route-policy c1-INBOUND in
maximum-prefix 1000000 75
route-policy c1-OUTBOUND out
send-extended-community-ebgp
default-originate
soft-reconfiguration inbound
!

VIP Advisor

Re: sub interface vlan issue

can you post both  the side config which include loopback interface information, also show ip route both the sides

BB
*** Rate All Helpful Responses ***
VIP Advisor

Re: sub interface vlan issue

Hello
The most simplistic would be to use an igp for NLRI (ripv2 would be approx) and advertise the vlan subnets and the loopback and establish a peering session on the loopbacks. the only problem you may encounter is the failover using subinterfaces due to the physical interfaces still being seen as up even if you had failure on the subinterface so you may need to adjust the igp timers to accommodate.

 

example:

router rip
ver 2
timers basic 15 45 45 60
no auto
network <your loopback>
network < vlan x>
network < vlan y>

 

router bgp xx
neigbour <remote loopback>
neigbour < ebgp-multihop x>
neighbour update-source < your loopback>



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: sub interface vlan issue

Hello,

 

For information my client is in another country than my country, can i use IGP or RIP in my situation.

Everyone's tags (1)
VIP Advisor

Re: sub interface vlan issue

Hello


@Abdoulka wrote:

Hello,

For information my client is in another country than my country, can i use IGP or RIP in my situation.

 

nt TenGigE0 / 6/3 / 0.2 
Address IPv4 192.168.1.225 255.255.255.252 
dot1q vlan 2 
!

Int TenGigE0 / 6/3 / 0.3 
Address IPv4 192.168.1.230 255.255.255.252 
dot1q vlan 3 
ip route 197.16.12.249/32 192.168.1.226 
ip route 197.16.12.249/32 196.168.1.230


If these two subnets are reachable between sites I cannot see why not -  The example provided should provide you with the resiliency you desire



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards