cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
895
Views
0
Helpful
3
Replies

Switch not relaying traffic from all VLANs to router

woodkir000
Level 1
Level 1

Capture.PNG

Hi all, I'm a student (so please don't roast me too hard ;)) and our class has, for a while, been working on VLANning with VLSMing. Until recently I haven't struggled a lot with it, but I've found that now that there's several switches in the mix, I'm having an issue where a switch connected to the router (the switch connected to the lower router on G0/0) will not relay all traffic, or in this case pings, from VLANs that it doesn't have an assigned port and computer to.

To be more specific to the screenshot shown, I'm trying to ping VLAN 10's gateway using the computer on F0/2 on the top right switch. However, whenever I try to ping it and look at the packet in simulation mode, it makes its way to the switch (whose computers have VLANS 30, 40, and 50 active) on the router's G0/0, but then drops the packet, saying "The active VLAN interface is not up. The ARP process ignores the frame." I've checked and am certain I've configured my gateway and the computer's IPs correctly, so that can't be the issue. I tried making an explicit list of all the VLANs in use for the gigabit ports on the switches, which are in trunk mode.

Here's all the ports for the G0/0 switch:

 

Spoiler

interface FastEthernet0/1

switchport access vlan 30

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 40

switchport mode access

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport trunk allowed vlan 10,20,30,40,50,60

switchport mode trunk

!

 

interface GigabitEthernet0/2

switchport trunk allowed vlan 10,20,30,40,50,60

switchport mode trunk

!

Here's the top right switch's ports:

Spoiler

interface FastEthernet0/1

switchport access vlan 60

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 20

switchport mode access

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

switchport mode trunk

!

interface GigabitEthernet0/2

switchport mode trunk

!

Here's the running config for the router (ignore the G0/1 stuff):

Spoiler

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 10

ip address 10.100.7.254 255.255.248.0

!

interface GigabitEthernet0/0.20

encapsulation dot1Q 20

ip address 10.100.8.254 255.255.255.0

!

interface GigabitEthernet0/0.30

encapsulation dot1Q 30

ip address 10.100.9.254 255.255.255.0

!

interface GigabitEthernet0/0.40

encapsulation dot1Q 40

ip address 10.100.10.126 255.255.255.128

!

interface GigabitEthernet0/0.50

encapsulation dot1Q 50

ip address 10.100.10.190 255.255.255.192

!

interface GigabitEthernet0/0.60

encapsulation dot1Q 60

ip address 10.100.10.254 255.255.255.192

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.10

encapsulation dot1Q 10

ip address 10.110.0.254 255.255.255.0

!

interface GigabitEthernet0/1.20

encapsulation dot1Q 20

ip address 10.110.1.254 255.255.255.0

!

interface GigabitEthernet0/1.30

encapsulation dot1Q 30

ip address 10.110.2.126 255.255.255.128

!

interface GigabitEthernet0/1.40

encapsulation dot1Q 40

ip address 10.110.2.254 255.255.255.128

!

interface GigabitEthernet0/1.50

encapsulation dot1Q 50

ip address 10.110.3.62 255.255.255.192

!

interface GigabitEthernet0/1.60

encapsulation dot1Q 60

ip address 10.110.3.78 255.255.255.240

!

interface Serial0/0/0

ip address 100.5.5.1 255.255.255.252

clock rate 4000000

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Serial0/1/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/1/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 100

log-adjacency-changes

network 10.100.0.0 0.0.7.255 area 0

network 10.100.8.0 0.0.0.255 area 0

network 10.100.9.0 0.0.0.255 area 0

network 10.100.10.0 0.0.0.127 area 0

network 10.100.10.128 0.0.0.63 area 0

network 10.100.10.192 0.0.0.63 area 0

network 10.110.0.0 0.0.0.255 area 0

network 10.110.1.0 0.0.0.255 area 0

network 10.110.2.0 0.0.0.127 area 0

network 10.110.2.128 0.0.0.127 area 0

network 10.110.3.0 0.0.0.63 area 0

network 10.110.3.64 0.0.0.15 area 0

network 100.5.5.0 0.0.0.3 area 0

!

Already asked my teacher but his answers were never very clear and he was busy helping others so that's why I'm turning to this forum haha. Thanks in advance, and let me know if you need more info.

 

3 Replies 3

Martin L
VIP
VIP

you can attach your PT file here in a zip format for us to take look;

Regards, ML
**Please Rate All Helpful Responses **

NetworkDave
Spotlight
Spotlight

@woodkir000,

You did well in troubleshooting. Using simulation mode was especially good. It is like using a packet analyzer (such as Wireshark) on a test or production network.

The switch, where the pings fail, is telling you what the problem is..."The active VLAN interface is not up". In this case, the active VLAN interface is the one you're using (VLAN 10). This condition is usually because the VLAN is not configured on the switch or the VLAN interface is administratively down. A VLAN needs to be configured on all switches that it is associated with.

As @Martin L advised, please provide the zipped packet tracer file with your question. this will help the community to better serve you.

HTH

----------------------------------------------------------------------------------------------------
Remember to mark helpful posts and mark the correct answer as a solution; It helps other users with similar questions.

Bryson F
Level 1
Level 1

@woodkir000 

I hope your class is going well but i am going to give you a few cheat codes when trouble shooting VLANs. I will try to keep this post short and understandable but let me know if you have any questions.

Switch# "Show interface description" (shortened version of the command is "sho int desc") with this you can see the descriptions quickly of all your interfaces VLAN included and you can see the state of them whether up or down.  So use this command to look at your vlans and make sure that all of them say UP on status and UP on protocol. Now with that if one does not say up do a "Show vlan" here you need to match each vlan that populated on show int desc. 

if you are missing one type --> configuration terminal --> vlan ##--> name "its name/desc" no shut

also you can skip this step by configuring an interface with a vlan for example--> Switch# conf t-->switch(config)# interface g1/0/1-->switch(config-if)# switch mode access--> switch access vlan##(new vlan) and it should populate with a message saying something like creating vlan ## blah blah blah. 

Sorry i know this is getting long but another command to help you in the future to trouble shoot physical issues is "show interface status" this will give you information about speed, duplex settings, SFP information, the line and protocol status of the interface, it will even show you "err-disabled" or "disabled" if the port was manual turned of or shut down from port security commands it is a great tool and i recommend using that as a first look if you cannot connect to something from your switch. 

If you have any other questions please let us know, and i hope you post more issues in the future here this is a great place to get help from some really smart people. like 115% of the people here make me feel like i dont know enough cisco so its a great place.

 

Review Cisco Networking for a $25 gift card