cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
273
Views
1
Helpful
2
Replies

Unable to configure internet on CISCO 1111-4P router.

amitpanwar
Level 1
Level 1

DEVICE : CISCO 1111-4P
WAN PORTS : 2 no.  ( INTERNET FORM 2 SEPRATE ISP'S)
LAN PORTS : 4 (IN SINGLE VLAN)

ISP 1 (POWERGRID)  : G0/0/0 ---------------CISCO 1111-4P    ---------  G0/1/0 : LAN PORT

ISP 2 (RAILTETL)       : G0/0/1 ----------------                            ---------  G0/1/1  : LAN PORT

I UANBLE TO CONFIGURE INTERNETT SHARING IN WAN TO LAN PORTS. I WANT TO  MERGE BANDWDITH OF 2 ISP'S AND SHARE IN LAN.

REQUEST TO PROVIDE CLI CONFIGURATION OF MERGING BANDWITH OF 2 ISP AND PROVIDING INTNET IN 2 WAN PORTS AND  SHARING IT ON LAN PORTS.

THNAKS IN ADVANCE.

 

2 Replies 2

balaji.bandi
Hall of Fame
Hall of Fame

There are couple of ways to do this -  below configuration help you if you have 2 subnets one go to ISP1 and 2 go to ISP2 

On the bottom of the Blog you see single Lan Subnet config

https://www.balajibandi.com/?p=1643

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hello,

this is what I have come up with (I think it is similar to what @balaji.bandi suggests, my apologies if it is redundant:

! Enable IP routing on the router
ip routing

! Define ACLs to match traffic for each LAN and ISP connection
access-list 10 permit <source_subnet1> <source_wildcard_mask1>
access-list 20 permit <source_subnet2> <source_wildcard_mask2>

! Configure static routes for each ISP connection
ip route 0.0.0.0 0.0.0.0 <ISP1_next_hop> track 1
ip route 0.0.0.0 0.0.0.0 <ISP2_next_hop> track 2

! Configure IP SLA to track the availability of ISP connections
ip sla 1
icmp-echo <ISP1_next_hop>
frequency 10
ip sla schedule 1 life forever start-time now
ip sla 2
icmp-echo <ISP2_next_hop>
frequency 10
ip sla schedule 2 life forever start-time now

! Configure tracking objects for IP SLA
track 1 ip sla 1 reachability
track 2 ip sla 2 reachability

! Configure NAT overload (PAT) for each LAN interface
ip nat inside source list 10 interface <WAN_interface1> overload
ip nat inside source list 20 interface <WAN_interface2> overload

! Configure PBR to route traffic based on source IP address for each LAN
route-map ISP1 permit 10
match ip address 10
set ip next-hop verify-availability <ISP1_next_hop> 1 track 1
route-map ISP2 permit 20
match ip address 20
set ip next-hop verify-availability <ISP2_next_hop> 1 track 2

! Apply the route maps to the LAN-facing interfaces
interface <LAN_interface1>
ip policy route-map ISP1
ip nat inside
interface <LAN_interface2>
ip policy route-map ISP2
ip nat inside

! Apply the route maps to the WAN-facing interfaces
interface <WAN_interface1>
ip policy route-map ISP1
interface <WAN_interface2>
ip policy route-map ISP2

Review Cisco Networking for a $25 gift card