cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4572
Views
0
Helpful
9
Replies
Highlighted
Beginner

Unable to connect 887VA Router to ISP via ADSL

I have been trying to connect a  new Cisco 887VA Router to the Internet using ADSL via PPPoE and have  been unsuccessful. The DSL line is active and functioning correctly  since the current "old" router is connected and working without any  problems (the "old" DLink router is connected to an Alcatel DSL Modem).  AT&T provides the ADSL service to the office. When the Cisco Router  is connected it tries to negotiate a connection via PPPoE on the WAN  interface but utlimately fails. The IP for the WAN interface is dynamic.  Any solutions or suggestions would be greatly appreciated.

Below is the current configuration of the router.

!

! Last configuration change at 00:43:54 UTC Sun Jun 26 2011

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxx-r1

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 xxxx.

!

no aaa new-model

!

memory-size iomem 10

crypto pki token default removal timeout 0

!

!

ip source-route

!

!

!

ip dhcp excluded-address 192.168.0.1 192.168.0.25

!

ip dhcp pool xxx-net

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.1

   dns-server 68.94.156.1 68.94.157.1

   lease 0 22

!

!

ip cef

ip domain name xxxx.local

no ipv6 cef

!

!

multilink bundle-name authenticated

license udi pid CISCO887VA-SEC-K9 sn FTX15040JNR

!

!

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

pppoe-client dial-pool-number 1

no fair-queue

!

interface ATM0

description ADSL to SBC/ATT

no ip address

no atm ilmi-keepalive

hold-queue 224 in

pvc 0/35

!

bundle enable

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1412

!

interface Dialer1

ip address negotiated

no ip redirects

no ip unreachables

no ip proxy-arp

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxx@sbcglobal.net

ppp chap password 7 xxxx

ppp pap sent-username xxxx@sbcglobal.net password 7 xxxx

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

ip nat inside source list NAT-ACL interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip access-list standard VTY-ACL

permit 192.168.0.0 0.0.0.255

!

ip access-list extended NAT-ACL

permit ip 192.168.1.0 0.0.0.255 any

!

logging esm config

!

!

!

!

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

access-class VTY-ACL in

password 7 xxxx

login

transport input all

!

end

9 REPLIES 9
Participant

Unable to connect 887VA Router to ISP via ADSL

Hi Jose,

I'd add "pppoe enable group global" under the ethernet interface, then enable "deb ppp nego" and collect the logs, to check if the negotiation is starting (and why it fails).

Hope this helps

Marco

Beginner

Unable to connect 887VA Router to ISP via ADSL

Hi Marco,

Thanks for responding. I'll check and see what the logs say after adding the "pppoe enable group global" to the config.

Beginner

Re: Unable to connect 887VA Router to ISP via ADSL

Hi Marco,

I added "pppoe enable group global" to the config and then used the following debug command, deb pppoe events. In looking at the log, it showed that PADI's were being sent out through the WAN interface but no PADO's were being received from the ISP. In essence the PADI timer kept expiring (see below). I also checked the status of the interfaces and found that ATM and Dialer interfaces were up and connected but the physical WAN interface (Ethernet 0) was neither up or connected (see below). Any other suggestions you may have would greatly be appreciated.

Log:

Cisco IOS Software, C880 Software (C880DATA-UNIVERSALK9-M), Version 15.1(2)T1, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Wed 11-Aug-10 18:20 by prod_rel_team

*Jul 18 01:28:35.367: %SNMP-5-COLDSTART: SNMP agent on host xxxx is undergoing a cold start

*Jul 18 01:28:35.375: %SYS-6-BOOTTIME: Time taken to reboot after reload =   76 seconds

*Jul 18 01:28:35.407: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is OFF

*Jul 18 01:28:35.407: %CRYPTO-6-GDOI_ON_OFF: GDOI is OFF

*Jul 18 01:28:36.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, changed state to down

*Jul 18 01:28:36.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to

down

*Jul 18 01:28:36.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1, changed state to

down

*Jul 18 01:28:36.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2, changed state to

down

*Jul 18 01:28:36.363: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet3, changed state to

down

*Jul 18 01:29:04.755: %CONTROLLER-5-UPDOWN: Controller VDSL 0, changed state to up

*Jul 18 01:29:06.759: %LINK-3-UPDOWN: Interface Ethernet0, changed state to down

*Jul 18 01:29:13.911: %LINK-3-UPDOWN: Interface ATM0, changed state to up

*Jul 18 01:29:14.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to up

*Jul 18 01:29:21.771: PPPoE:ATM0 0/35, Got ATM VC Event

*Jul 18 01:29:21.951: PPPoE:ATM0 0/35, Got ATM VC Event

*Jul 18 01:29:36.511:  padi timer expired

*Jul 18 01:29:36.511:  Sending PADI: Interface = Ethernet0

*Jul 18 01:30:08.767:  padi timer expired

*Jul 18 01:30:08.767:  Sending PADI: Interface = Ethernet0

*Jul 18 01:30:41.047:  padi timer expired

*Jul 18 01:30:41.047:  Sending PADI: Interface = Ethernet0

Interfaces:

Interface                  IP-Address      OK? Method Status                Protocol

ATM0                       unassigned      YES NVRAM  up                    up

Dialer1                    unassigned      YES NVRAM  up                    up

Ethernet0                  unassigned      YES NVRAM  down                  down

FastEthernet0              unassigned      YES unset  up                    down

FastEthernet1              unassigned      YES unset  up                    down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

NVI0                       unassigned      YES unset  administratively down down

Vlan1                      192.168.0.1     YES NVRAM  up                    down

Hall of Fame Master

Re: Unable to connect 887VA Router to ISP via ADSL

Update IOS.

Beginner

Re: Unable to connect 887VA Router to ISP via ADSL

Hi Paolo,

Thanks for your reply. I was beginning to think an IOS update would be needed. I will download the latest, which is 15.1.3T1 for the 887VA, and do the upgrade.

Hall of Fame Master

Re: Unable to connect 887VA Router to ISP via ADSL

You are missing pppoe config under pvc 0/35

Also

interface Vlan1

ip tcp adjust-mss 1452

interface Dialer1

no ip mtu 1452

mtu 1492

no cdp enable

Beginner

Unable to connect 887VA Router to ISP via ADSL

Hi Paolo,

Thanks for the suggestions you provided. I will edit the config as suggested. Hopefully it will work out.

Beginner

Unable to connect 887VA Router to ISP via ADSL

We have a similar problem with connection, do you have a final config that did work so that we can compare it to our own

?

Beginner

Re: Unable to connect 887VA Router to ISP via ADSL

Did you solve your issue?

If not try this my friend

Controller VDSL 0

                operating mode adsl2+

I've choose ADSL2+ as it's what is provided in Morocco

And don't forget to configure PPPoE on PVC under ATM like that; as this the group you're using in your int Dialer 1:

pvc 8/35

  pppoe-client dial-pool-number 1

Good luck :-)

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards