cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
754
Views
0
Helpful
3
Replies

using a 3750 switch to route

lcaruso
Level 6
Level 6

I need to use a 3750 switch running 12.2 code to route between two networks in a test setup.

Switch#sh ver
Cisco IOS Software, C3750 Software (C3750-IPSERVICES-M), Version 12.2(25)SEE2, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2006 by Cisco Systems, Inc.

The idea for the test setup is 3750 emulates a client's live network which is two routers having a site-to-site tunnel connecting from their ISPs. This will allow me to test the tunnel configuration with the router configs that are in production but replacing one of the routers with an ASA.

My question is how do I use the 3750 to do this?

I assume create two vlans with ip addressing that replicates each router’s isp connection, assign those to different switchports, and connect the router and the ASA to  those switchports, but what about the routing?

Or is the above approach wrong to begin with? Thanks for any guidance.

1 Accepted Solution

Accepted Solutions

hobbe
Level 7
Level 7

Hi

You are on the right track, I use my 3750x like that all the time.

its perfect to test IPsec tunnels and firewall stuff aswell.

There is actually two ways of doing this.

all virtual with svi

interface gig1/0/1

switchport access vlan 10

switchport mode access

interface gig1/0/2

switchport access vlan 20

switchport mode access

interface Vlan10

ip address 192.168.10.1 255.255.255.0

interface Vlan20

ip address 192.168.20.1 255.255.255.0

To start routing you need to specify the command:
ip routing
.
Or if you want to do it with cables.
Interface gig1/0/1
no switchport
ip address 192.168.10.1 255.255.255.0
interface gig1/0/2
no switchport
ip address 192.168.20.1 255.255.255.0
Interface gig1/0/3
Switchport access vlan 10
switchport mode access
interface gig 1/0/4
Switchport access vlan 10
switchport mode access
Interface gig 1/0/5
switchport access vlan 20
switchport mode access
interface gig 1/0/6
switchport access vlan 20
switchport mode access
.
If you do it with cables then you have the possibillity to pull the cables to test connectivity fx.
and ofcourse you need to do a no shut on any interface that is shutdown.
.
Good luck
HTH

Message was edited by: hobbe

View solution in original post

3 Replies 3

lcaruso
Level 6
Level 6

Something like this?

IP routing

Vlan 851

Name 851_router

Vlan 1811

Name 1811_router

Interface vlan851

Ip address x.x.x.x 255.255.255.0

No shut

Interface vlan1811

Ip address x.x.x.x 255.255.255.0

No shut

Interface Fa 1/0/1

Switchport mode access

Switcport access vlan 851

No shut

Interface Fa 1/0/2

Switchport mode access

Switcport access vlan1811

No shut

hobbe
Level 7
Level 7

Hi

You are on the right track, I use my 3750x like that all the time.

its perfect to test IPsec tunnels and firewall stuff aswell.

There is actually two ways of doing this.

all virtual with svi

interface gig1/0/1

switchport access vlan 10

switchport mode access

interface gig1/0/2

switchport access vlan 20

switchport mode access

interface Vlan10

ip address 192.168.10.1 255.255.255.0

interface Vlan20

ip address 192.168.20.1 255.255.255.0

To start routing you need to specify the command:
ip routing
.
Or if you want to do it with cables.
Interface gig1/0/1
no switchport
ip address 192.168.10.1 255.255.255.0
interface gig1/0/2
no switchport
ip address 192.168.20.1 255.255.255.0
Interface gig1/0/3
Switchport access vlan 10
switchport mode access
interface gig 1/0/4
Switchport access vlan 10
switchport mode access
Interface gig 1/0/5
switchport access vlan 20
switchport mode access
interface gig 1/0/6
switchport access vlan 20
switchport mode access
.
If you do it with cables then you have the possibillity to pull the cables to test connectivity fx.
and ofcourse you need to do a no shut on any interface that is shutdown.
.
Good luck
HTH

Message was edited by: hobbe

Thanks for your response.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card