12-22-2016 07:11 PM - edited 03-05-2019 07:43 AM
Hello,
I setup a GNS3 lab to test VRF and EIGRP routing. It's a simple lab where I have two switches(VSS_Dist1 & Core1). Both have VRF SharedVRF, SVI 992, which is in VRF SharedVRF, and EIGRP 900. I advertised network 172.26.90.0/24 on both EIGRP processes on both switches. Both switches established EIGPR relationship; however, there's no entries for the any routes advertised through EIGRP. See config below.
Why can't I ping the SVI of each switch? Also, why isn't EIGRP advertising the networks of the interfaces I included in the EIGPR process?
Thanks in advance.
========================================================================
Configuration on Switch VSS_Dist1_LAB
VSS_Dist1_LAB#
ip vrf SharedVRF
!
interface Vlan992
description SharedVRF to Core1_LAB
ip vrf forwarding SharedVRF
ip address 172.26.90.17 255.255.255.248
!
router eigrp 1902
no auto-summary
!
address-family ipv4 vrf SharedVRF
network 2.2.2.2 0.0.0.0
network 172.26.90.0 0.0.0.255
no auto-summary
autonomous-system 900
exit-address-family
!
Output:
VSS_Dist1_LAB#sh ip route eigrp 900
VSS_Dist1_LAB#
VSS_Dist1_LAB#sh ip eigrp vrf SharedVRF neighbors
IP-EIGRP neighbors for process 900
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.26.90.19 Vl992 11 00:41:24 2003 5000 0 11
VSS_Dist1_LAB#ping vrf SharedVRF 172.26.90.19
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.26.90.19, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
VSS_Dist1_LAB#
============================================================================
Configuration on Switch VSS_Dist1_LAB
Core1_LAB#
ip vrf SharedVRF
!
interface Vlan992
description SharedVRF to VSS_DIST1
ip vrf forwarding SharedVRF
ip address 172.26.90.19 255.255.255.248
!
router eigrp 1902
no auto-summary
!
address-family ipv4 vrf SharedVRF
network 2.2.2.2 0.0.0.0
network 172.26.90.0 0.0.0.255
no auto-summary
autonomous-system 900
exit-address-family
!
Core1_LAB#sh ip eigrp vrf SharedVRF neighbors
IP-EIGRP neighbors for process 900
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.26.90.17 Vl992 14 00:45:31 2071 5000 0 7
Core1_LAB#
Core1_LAB#ping vrf SharedVRF 172.26.90.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.26.90.17, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
======================
12-23-2016 05:04 AM
Hi Zekebashi,
1. Ping you initiated to test the connectivity should work without EIGRP also. There is something else which is blocking this ping. "debug ip icmp" output may help to identify the direction of the problem.
2. If you have route via EIGRP and via directly connected, you will never see it via EIGRP in route table.
3. You must enter command "show ip eigrp vrf SharedVRF topology" to check them. Output will look like below.
#sh ip eigrp vrf SharedVRF topology
EIGRP-IPv4 Topology Table for AS(900)/ID(172.26.90.17) VRF(SharedVRF)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 172.26.90.16/29, 1 successors, FD is 281600
via Connected, Vlan992.
Please rate if it helped
HTH
-Amit
01-04-2017 07:44 PM
Thanks for the input.
The ping still doesn't work. I still can't ping neither the loopback nor the SVI interfaces.
Here's the config on Core1 sw:
Core1_LAB#sh run
Building configuration...
Current configuration : 2267 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Core1_LAB
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
ip vrf SharedVRF
rd 90:17
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip tcp synwait-time 5
!
interface Loopback0
ip vrf forwarding SharedVRF
ip address 1.1.1.1 255.255.255.255
!
interface Vlan992
ip vrf forwarding SharedVRF
ip address 172.26.90.19 255.255.255.248
!
router eigrp 1902
no auto-summary
!
address-family ipv4 vrf SharedVRF
network 1.1.1.1 0.0.0.0
network 172.26.90.16 0.0.0.7
no auto-summary
autonomous-system 900
exit-address-family
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.26.90.17
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
==================================================
VSS_Dist1_LAB#sh run
Building configuration...
Current configuration : 4009 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VSS_Dist1_LAB
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
ip vrf SharedVRF
rd 90:17
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ip tcp synwait-time 5
!
!
interface Loopback0
ip vrf forwarding SharedVRF
ip address 2.2.2.2 255.255.255.255
interface Vlan992
description SharedVRF to EPACore
ip vrf forwarding SharedVRF
ip address 172.26.90.17 255.255.255.248
!
router eigrp 1902
no auto-summary
!
address-family ipv4 vrf SharedVRF
network 2.2.2.2 0.0.0.0
network 172.26.90.16 0.0.0.7
no auto-summary
autonomous-system 900
exit-address-family
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.26.90.19
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
VSS_Dist1_LAB#
================
Output when trying to ping the lo0(2.2.2.2) from Core1
Core1_LAB#ping vrf SharedVRF 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.
*Mar 1 01:03:20.703: ICMP: echo reply rcvd, src 2.2.2.2, dst 172.26.90.19.
*Mar 1 01:03:22.735: ICMP: echo reply rcvd, src 2.2.2.2, dst 172.26.90.19.
*Mar 1 01:03:24.775: ICMP: echo reply rcvd, src 2.2.2.2, dst 172.26.90.19..
Success rate is 0 percent (0/5)
Core1_LAB#
*Mar 1 01:03:26.879: ICMP: echo reply rcvd, src 2.2.2.2, dst 172.26.90.19
Core1_LAB#
*Mar 1 01:03:28.907: ICMP: echo reply rcvd, src 2.2.2.2, dst 172.26.90.19
Core1_LAB#
=========================================================
Output when trying to ping SVI 172.26.90.17 on Core1
Core1_LAB#ping vrf SharedVRF 172.26.90.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.26.90.17, timeout is 2 seconds:
..
*Mar 1 01:04:27.691: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:29.719: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:31.759: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
Success rate is 0 percent (0/5)
Core1_LAB#
*Mar 1 01:04:33.787: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19
Core1_LAB#
*Mar 1 01:04:35.827: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19
Core1_LAB#
===========================
Core1_LAB#sh ip route vrf SharedVRF
Routing Table: SharedVRF
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/156160] via 172.26.90.17, 00:38:22, Vlan992
172.26.0.0/29 is subnetted, 1 subnets
C 172.26.90.16 is directly connected, Vlan992
Core1_LAB#
----
Core1_LAB#sh ip eigrp vrf SharedVRF topology
IP-EIGRP Topology Table for AS(900)/ID(1.1.1.1) Routing Table: SharedVRF
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 2.2.2.2/32, 1 successors, FD is 156160
via 172.26.90.17 (156160/128256), Vlan992
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0
P 172.26.90.16/29, 1 successors, FD is 28160
via Connected, Vlan992
Core1_LAB#
Thanks in advance.
~zK
01-06-2017 12:00 AM
Hi zK,
I see that ICMP echo reply is coming.
Core1_LAB#ping vrf SharedVRF 2.2.2.2
*Mar 1 01:04:27.691: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:29.719: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:31.759: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:33.787: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19
*Mar 1 01:04:35.827: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19
Core1_LAB#ping vrf SharedVRF 172.26.90.17
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.26.90.17, timeout is 2 seconds:
..
*Mar 1 01:04:27.691: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:29.719: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:31.759: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19.
*Mar 1 01:04:33.787: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19
*Mar 1 01:04:35.827: ICMP: echo reply rcvd, src 172.26.90.17, dst 172.26.90.19
Can you try connecting some PC behind the switch and check if PING is good?
Routes are visible in EIGRP topology
Core1_LAB#sh ip eigrp vrf SharedVRF topology
IP-EIGRP Topology Table for AS(900)/ID(1.1.1.1) Routing Table: SharedVRF
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 2.2.2.2/32, 1 successors, FD is 156160
via 172.26.90.17 (156160/128256), Vlan992
P 1.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0
P 172.26.90.16/29, 1 successors, FD is 28160
via Connected, Vlan992
HTH
-Amit
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide