cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1517
Views
0
Helpful
1
Replies

VRF Lite route leaking

barney.pause
Beginner
Beginner

I have a router that I configured to emulate the MPLS network of a customer. Each customer sites are connected to this router and have a EIGRP adjacency with it. On the MPLS router, a VRF has been configured for each sites and route leaking is used for route exchange between the VRF.

It works but there is something that is puzzling me. On the customer sites routers, the routes for the other sites appear as EIGRP Internal routes. Since these routes are being redistributed from EIGRP to BGP and then from BGP to EIGRP I would have expected them to be external. Does anyone know why the routes are internal?

Here is the relevant part of the config of the MPLS router:

ip vrf HQ

rd 65000:1

route-target export 65000:1

route-target import 65000:2

route-target import 65000:3

!

ip vrf Remote1

rd 65000:2

route-target export 65000:2

route-target import 65000:1

route-target import 65000:3

!

ip vrf Remote2

rd 65000:3

route-target export 65000:3

route-target import 65000:1

route-target import 65000:2

router eigrp 100

!

address-family ipv4 vrf HQ autonomous-system 100

  redistribute bgp 65000 metric 100000 1500 255 1 1500

  network 0.0.0.0

  passive-interface default

  no passive-interface FastEthernet1/0

exit-address-family

!

address-family ipv4 vrf Remote1 autonomous-system 100

  redistribute bgp 65000 metric 100000 1500 255 1 1500

  network 0.0.0.0

  passive-interface default

  no passive-interface FastEthernet1/1

exit-address-family

!

address-family ipv4 vrf Remote2 autonomous-system 100

  redistribute bgp 65000 metric 100000 1500 255 1 1500

  network 0.0.0.0

  passive-interface default

  no passive-interface FastEthernet2/0

exit-address-family

passive-interface default

!

router bgp 65000

bgp log-neighbor-changes

!

address-family ipv4 vrf HQ

  redistribute eigrp 100

exit-address-family

!

address-family ipv4 vrf Remote1

  redistribute eigrp 100

exit-address-family

!

address-family ipv4 vrf Remote2

  redistribute eigrp 100

exit-address-family

The routes on one of the customer router:

Remote1#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks

D        10.1.1.0/24 [90/30720] via 10.1.2.1, 00:00:10, FastEthernet1/0

C        10.1.2.0/24 is directly connected, FastEthernet1/0

L        10.1.2.10/32 is directly connected, FastEthernet1/0

D        10.1.3.0/24 [90/30720] via 10.1.2.1, 00:00:10, FastEthernet1/0

D        10.100.1.0/24 [90/33280] via 10.1.2.1, 00:00:10, FastEthernet1/0

D        10.254.254.1/32 [90/158720] via 10.1.2.1, 00:00:10, FastEthernet1/0

D        10.254.254.2/32 [90/158720] via 10.1.2.1, 00:00:10, FastEthernet1/0

C        10.254.254.3/32 is directly connected, Loopback0

D        10.254.254.4/32 [90/158720] via 10.1.2.1, 00:00:10, FastEthernet1/0

Thanks

1 Reply 1

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

You are using the same EIGRP instance (100) for all 3 customers.

Try using a differnt EIGRP instance for each customer (100, 200.300) and test again.  Now, the route should show up as external.

HTH

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers