cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
417
Views
0
Helpful
1
Replies

VRF Lite

jahilnt10
Level 1
Level 1

I'm just testing this out. I have configured two VRF instance. And I'm exporting and importing vrf table from Cust-A to vice versa.

ip vrf Cust-A

rd 1:1

route-target export 1:1

route-target import 1:1

route-target import 2:2

!

ip vrf Cust-B

rd 2:2

route-target export 2:2

route-target import 2:2

route-target import 1:1

interface FastEthernet0/1/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip mroute-cache

load-interval 30

full-duplex

no cdp enable

!

interface FastEthernet0/1/0.1

encapsulation dot1Q 99

ip vrf forwarding Cust-A

ip address 10.192.168.1 255.255.255.0

no cdp enable

!

interface FastEthernet0/1/0.2

encapsulation dot1Q 169

ip vrf forwarding Cust-B

ip address 10.192.169.1 255.255.255.0

no cdp enable

If I do show ip route vrf Cust-A or Cust-B ..

show ip route vrf Cust-B

10.0.0.0/24 is subnetted, 1 subnets

C 10.192.169.0 is directly connected, FastEthernet0/1/0.2

show ip route vrf Cust-A

Routing Table: Cust-A

10.0.0.0/24 is subnetted, 1 subnets

C 10.192.168.0 is directly connected, FastEthernet0/1/0.1

If i'm importing and exporting route target from both VRf than both VRF should exchange routing table and I must see Cust-A routes in Cust-B VRF table and vice versa..

what i'm doing wrong here...

Second, what if i want my Cust-B users to access internet while internet default route is in global table?

1 Reply 1

royalblues
Level 10
Level 10

I think you would require BGP to import the routes eventhough you do not run MPLS or peer with anyone in VRF lite

Can you add the following and let us know how it goes

router bgp 65530

no synchronization

bgp log-neighbor-changes

no auto-summary

!

address-family ipv4 vrf Cust-A

redistribute connected

no synchronization

exit-address-family

!

address-family ipv4 vrf Cust-B

redistribute connected

no synchronization

exit-address-family

!

HTH

Narayan