cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
821
Views
0
Helpful
8
Replies

VRFs and OSPF

Andrew White
Level 2
Level 2

Hello,

 

I've been trying to run 2 VRFs in a small GNS3 lab to help me understand it better before doing in on real kit in a couple of weeks.  I've managed to do it in EIGRP before on other networks but I've not tried in in EIGRP.

 

I had another post but it go way too messy, so I thought I'd start a fresh lab and see how I get on.

 

Here is the topology

ospf1.PNG

 

R1#
R1#sh ip ospf nei
R1#
R2#
R2#sh ip ospf nei
R2#

R1 config

 

ip vrf Customer-A
!
ip vrf Customer-B
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/0.1
 description Customer-A
 encapsulation dot1Q 5
 ip vrf forwarding Customer-A
!
interface GigabitEthernet0/0.2
 description Customer-B
 encapsulation dot1Q 10
 ip vrf forwarding Customer-B
!
interface GigabitEthernet0/1
 ip vrf forwarding Customer-A
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 ip vrf forwarding Customer-B
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1 vrf Customer-A
 router-id 1.1.1.1
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0
!
router ospf 2 vrf Customer-B
 router-id 1.1.1.2
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0

R2

ip vrf Customer-A
!
ip vrf Customer-B
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 5
 ip vrf forwarding Customer-A
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/0.2
 encapsulation dot1Q 10
 ip vrf forwarding Customer-B
 ip address 10.12.12.2 255.255.255.0
!
interface GigabitEthernet0/1
 ip vrf forwarding Customer-A
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/2
 ip vrf forwarding Customer-B
 ip address 10.20.20.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/3
 no ip address
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1 vrf Customer-A
 router-id 2.2.2.1
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0
!
router ospf 2 vrf Customer-B
 router-id 2.2.2.2
 capability vrf-lite
 network 10.0.0.0 0.255.255.255 area 0

R1

 

R1#sh ip ospf int
GigabitEthernet0/2 is up, line protocol is up
  Internet Address 10.10.10.1/24, Area 0, Attached via Network Statement
  Process ID 2, Router ID 1.1.1.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.2, Interface address 10.10.10.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 1 msec, maximum is 1 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/1 is up, line protocol is up
  Internet Address 10.10.10.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 10.10.10.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
R1#

R2

 

R2#sh ip ospf interface
GigabitEthernet0/2 is up, line protocol is up
  Internet Address 10.20.20.2/24, Area 0, Attached via Network Statement
  Process ID 2, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.20.20.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0.2 is up, line protocol is up
  Internet Address 10.12.12.2/24, Area 0, Attached via Network Statement
  Process ID 2, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.12.12.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 1 msec, maximum is 1 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/1 is up, line protocol is up
  Internet Address 10.20.20.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.1, Interface address 10.20.20.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:09
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
GigabitEthernet0/0.1 is up, line protocol is up
  Internet Address 10.12.12.2/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 2.2.2.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 2.2.2.1, Interface address 10.12.12.2
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1/1, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
R2#

R1 and R2 are not forming neighbour relationships with each other or the other routers.

1 Accepted Solution

Accepted Solutions

Hello


@Andrew White wrote:
OSPF neighbour relationships are not forming with R1 or R2 or other routers. Do I need to add RD's?

You need addressing on R1 sub-interfaces

R1

interface GigabitEthernet0/0.1
description Customer-A
encapsulation dot1Q 5
ip vrf forwarding Customer-A
ip address ?????

 

interface GigabitEthernet0/0.2
description Customer-B
encapsulation dot1Q 10
ip vrf forwarding Customer-B
ip address ?????

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

8 Replies 8

balaji.bandi
Hall of Fame
Hall of Fame

You have posted to HLD and config ? but what is the issue here ?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

OSPF neighbour relationships are not forming with R1 or R2 or other routers. Do I need to add RD's?

Hello


@Andrew White wrote:
OSPF neighbour relationships are not forming with R1 or R2 or other routers. Do I need to add RD's?

You need addressing on R1 sub-interfaces

R1

interface GigabitEthernet0/0.1
description Customer-A
encapsulation dot1Q 5
ip vrf forwarding Customer-A
ip address ?????

 

interface GigabitEthernet0/0.2
description Customer-B
encapsulation dot1Q 10
ip vrf forwarding Customer-B
ip address ?????

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

OMG!

 

What's the matter with me, I've been looking at this for ages and missed something so simple.

While I have you Paul what are RDs used for in OSPF VRFs?

Hello


@Andrew White wrote:

While I have you Paul what are RDs used for in OSPF VRFs?


VRF RD's are used  keep the addressing within a  vrf separate from other vrfs, it makes those prefixes unique, Hence why you can have the same addressing in mutiple vrfs in multiple vpns


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

I've used the same addressing in my 2 VRFs should I (if in the real world) be adding RDs?

 

If so what should add to R1 and R2?  Or is it more related as global identifier like at as ISP rather than internal private subnets between customers?

Hello Andy

If you using vrf lite then in theory you dont need to use it, but defiantly when bgp mpls vpn is to be used it is indeed required so to make the addressing unique.


Have a look at this - Route Distinguishers


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Review Cisco Networking for a $25 gift card