cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4189
Views
10
Helpful
4
Replies
Highlighted
Beginner

1000v "channel-group auto mode active"

I'm trying to connect a pair of Nexus 5532UP's, with vPC, to a Nexus 1000v.  I'm running 4.2.1.SV1.4a. When I add the server's physical NICs to the dVS in vCenter, they fail to come up on the VSM and report link down (NoPortProfile).  If I take "channel-group auto mode active" out of the port-profile, or use "mode on" the links come up, but I want to use vPC on the Nexus 5k's.

'show run port-profile uplinks':

port-profile type ethernet uplinks

  vmware port-group

  switchport mode trunk

  switchport trunk allowed vlan 12,13,14,15

  channel-group auto mode active

  no shutdown

  system vlan 12,13,14,15

  state enabled

'show accounting log':

Thu Sep  1 22:17:57 2011:update:ppm.7239:admin:configure terminal ; interface Ethernet3/5, Ethernet3/7 ; channel-group auto mode active (FAILURE)

(the rest of the config in the port-profile report "SUCCESS" in the log)

So, what's the problem?  What should I look at next?  Downgrading the 1000v software?

Everyone's tags (6)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

1000v "channel-group auto mode active"

have found something like this in your infrastructure ?

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
  channel-group auto mode active
  no shutdown
  system vlan 100,101,102,103
  state enabled
# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
  switchport mode trunk
  vpc 1000
  switchport trunk allowed vlan 100-103,200-300
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable
  spanning-tree bpdufilter enable
!
interface Ethernet1/11
feature lacp
lacp offload

description ESX-Host1
  switchport mode trunk
  switchport trunk allowed vlan 100-103,200-300
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable
  spanning-tree bpdufilter enable
  channel-group 1000 mode active

View solution in original post

4 REPLIES 4
Highlighted
Beginner

1000v "channel-group auto mode active"

have found something like this in your infrastructure ?

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
  vmware port-group
  switchport mode trunk
  switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
  channel-group auto mode active
  no shutdown
  system vlan 100,101,102,103
  state enabled
# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
  switchport mode trunk
  vpc 1000
  switchport trunk allowed vlan 100-103,200-300
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable
  spanning-tree bpdufilter enable
!
interface Ethernet1/11
feature lacp
lacp offload

description ESX-Host1
  switchport mode trunk
  switchport trunk allowed vlan 100-103,200-300
  spanning-tree port type edge trunk
  spanning-tree bpduguard enable
  spanning-tree bpdufilter enable
  channel-group 1000 mode active

View solution in original post

Highlighted
Beginner

Re: 1000v "channel-group auto mode active"

Ah, so feature commands aren't unique to the hardware models.

'feature lacp' was missing. Thanks.

Sent from Cisco Technical Support iPhone App

Highlighted
Cisco Employee

Re: 1000v "channel-group auto mode active"

Above content was sourced from https://supportforums.cisco.com/docs/DOC-18222

Highlighted
Enthusiast

1000v "channel-group auto mode active"

After enabling lacp feature, I had to re-apply the port-profile using "no shut" command on each interafce.

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey