cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

5675
Views
0
Helpful
13
Replies
Highlighted
Contributor

4900M connection to HP Virtual Connect Flex 10

Trying to connect a HP-C7000 blade server with a Virtual Connect Flex 10 connection with 10Gb links to a Catalyst 4900M.

I have no control of the HP side. From the HP guide, we are following "HP Virtual Connect Ethernet Cookbook" "Scenario 1:5 - VLAN Tagging (802.1q) with Shared Uplink Set (SUS) with Link Aggregation using LACP (802.3ad) - VMware ESX"
On the 4900M, LLDP sees the Virtual Connect and LCAP up with 2 active links. Show interface on Ten1/1, Ten1/2, Port-Channel 1 shows 0 packets input.
Basically, we can not get any packets from the HP Server/VMware server side through the Catalyst 4900.
IOS version: 12.2(54)SG

Switch ports are as follows:

!

interface Port-channel1

description HP FLEX-10-VC

switchport trunk allowed vlan 4,8,10,11,16,22-24,69,99-101,156,192,300,500

switchport mode trunk

switchport nonegotiate

spanning-tree portfast trunk

interface TenGigabitEthernet1/1

description HP FLEX-10-VC

switchport trunk allowed vlan 4,8,10,11,16,22-24,69,99-101,156,192,300,500

switchport mode trunk

switchport nonegotiate

spanning-tree portfast trunk

channel-protocol lacp

channel-group 1 mode active

!

interface TenGigabitEthernet1/2

description HP FLEX-10-VC

switchport trunk allowed vlan 4,8,10,11,16,22-24,69,99-101,156,192,300,500

switchport mode trunk

switchport nonegotiate

spanning-tree portfast trunk

channel-protocol lacp

channel-group 1 mode active

13 REPLIES 13
Beginner

Re: 4900M connection to HP Virtual Connect Flex 10

I think the default for trunks is ISL, not 802.1q.   Try adding this to your Po1 interface (should trickle down):

switchport trunk encapsulation dot1q

Contributor

Re: 4900M connection to HP Virtual Connect Flex 10

With most new hardware and software the default is 802.1q and ISL is not supported.

Sent from my iPhone

Contributor

Re: 4900M connection to HP Virtual Connect Flex 10

Perhaps you should drop the LACP and just see if you can get one link up first.  Lower the complexity.

Contributor

Re: 4900M connection to HP Virtual Connect Flex 10

That was the last step we tried Thursday.

Cisco Employee

Re: 4900M connection to HP Virtual Connect Flex 10

Try doing this w/o trunking just to see if you can get packets to flow, so just an Port-channel in access mode.

How do you have your vSwitch configured?

Contributor

Re: 4900M connection to HP Virtual Connect Flex 10

Reinstalling VMware ESX corrected the problem. Looks like configuration issue between HP VC and ESX.

Sent from Cisco Technical Support iPhone App

Re: 4900M connection to HP Virtual Connect Flex 10

HP / Cisco interop --- make sure you're running MST

Beginner

4900M connection to HP Virtual Connect Flex 10

Hey Bill,

We are having similar issue.But we have traffic working without the port-channel.  When i put the ports into a port-channel. The two links go into suspended mode. We don't have LLDP configured on our switch. How did you fix ur issues? I would greatly appreciate any help.

Contributor

4900M connection to HP Virtual Connect Flex 10

It was a configuration error in the HP Flex Connect interfaces. The Flex Connect down-links had to be reconfigured to enable LACP and port-channeling.

Beginner

4900M connection to HP Virtual Connect Flex 10

Hi, if we configrue spanning-tree portfast trunk  in the port channel we can make a loop,isn't it ?? becouse the vNet insde the HP c7000 are like a Switch and delivr bpdu,so why do we set spanning-tree portfast trunk ?

thanks

Contributor

4900M connection to HP Virtual Connect Flex 10

The internal switch in the HP c7000 is different. It is ok to use spanning-tree portfast trunk.

Beginner

4900M connection to HP Virtual Connect Flex 10

But why Do we Need to Set this  command ? I Don't expect Access traffic,only trunk. There is no need portfast trunk Spam.treeg

Contributor

4900M connection to HP Virtual Connect Flex 10

This command starts passing traffic on all of the VLANs using the trunk. If the Flex Connect sees layer-1 come up but is unable to pass traffic it may think the interface is not working. I enable this on trunk connections to VMware hosts and Flex Connect interfaces. It is possible disabling portfast will not cause problems for the Flex Connect interfaces. You can test this in your environment and see what works.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here
This widget could not be displayed.