cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1265
Views
5
Helpful
2
Replies

Etherchannel / vPC from Nexus 5K to server is UP however the server errors: An illegal loopback occurred on adapter Check the configuration to verify that all adapters are connected to 802.3ad compliant switch ports

sgonsalv
Beginner
Beginner

Hi Guys,

We have farily stock standard config across our 5Ks as follows however while the port-channel / vPC is UP the server side complains with the following error continiously:

dc-224-dh3-rke17-sas1

interface port-channel644
switchport mode trunk
switchport trunk allowed vlan 100-101,948-949
speed 10000
vpc 644

interface Ethernet2/3
description RCCOMDC3-066-T2
switchport mode trunk
switchport trunk allowed vlan 100-101,948-949
channel-group 644 mode active

dc-224-dh3-rke18-sas1

interface port-channel644
switchport mode trunk
switchport trunk allowed vlan 100-101,948-949
speed 10000
vpc 644

interface Ethernet2/3

description RCCOMDC3-066-T1
switchport mode trunk
switchport trunk allowed vlan 100-101,948-949
channel-group 644 mode active

dc-224-dh3-rke17-sas1# sh vpc 644


vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
644 Po644 up success success 100-101,948
-949

dc-224-dh3-rke18-sas1# sh vpc 644


vPC status
----------------------------------------------------------------------------
id Port Status Consistency Reason Active vlans
------ ----------- ------ ----------- -------------------------- -----------
644 Po644 up success success 100-101,948
-949

dc-224-dh3-rke17-sas1# sh port-channel summary

<snip>

644   Po644(SD)   Eth      LACP      Eth2/3(P)

dc-224-dh3-rke18-sas1# sh port-channel summary

<snip>

644   Po644(SD)   Eth      LACP      Eth2/3(P)

The server itself is:

root@rccomdc3-066:~# modinfo i40e
filename:       /lib/modules/3.19.0-39-generic/kernel/drivers/net/ethernet/intel/i40e/i40e.ko
version:        1.3.47
license:        GPL
description:    Intel(R) Ethernet Connection XL710 Network Driver
author:         Intel Corporation, <e1000-devel@lists.sourceforge.net>
srcversion:     442A8B9F69471758CEE3988
alias:          pci:v00008086d00001588sv*sd*bc*sc*i*
alias:          pci:v00008086d00001587sv*sd*bc*sc*i*
alias:          pci:v00008086d00001589sv*sd*bc*sc*i*
alias:          pci:v00008086d00001586sv*sd*bc*sc*i*
alias:          pci:v00008086d00001585sv*sd*bc*sc*i*
alias:          pci:v00008086d00001584sv*sd*bc*sc*i*
alias:          pci:v00008086d00001583sv*sd*bc*sc*i*
alias:          pci:v00008086d00001581sv*sd*bc*sc*i*
alias:          pci:v00008086d00001580sv*sd*bc*sc*i*
alias:          pci:v00008086d0000157Fsv*sd*bc*sc*i*
alias:          pci:v00008086d00001574sv*sd*bc*sc*i*
alias:          pci:v00008086d00001572sv*sd*bc*sc*i*
depends:        configfs,ptp,vxlan
vermagic:       3.19.0-39-generic SMP mod_unload modversions
parm:           debug:Debug level (0=none,...,16=all) (int)

root@rccomdc3-066:~# modinfo i40e
filename:       /lib/modules/3.19.0-39-generic/kernel/drivers/net/ethernet/intel/i40e/i40e.ko
version:        1.3.47
license:        GPL
description:    Intel(R) Ethernet Connection XL710 Network Driver
author:         Intel Corporation, <e1000-devel@lists.sourceforge.net>
srcversion:     442A8B9F69471758CEE3988
alias:          pci:v00008086d00001588sv*sd*bc*sc*i*
alias:          pci:v00008086d00001587sv*sd*bc*sc*i*
alias:          pci:v00008086d00001589sv*sd*bc*sc*i*
alias:          pci:v00008086d00001586sv*sd*bc*sc*i*
alias:          pci:v00008086d00001585sv*sd*bc*sc*i*
alias:          pci:v00008086d00001584sv*sd*bc*sc*i*
alias:          pci:v00008086d00001583sv*sd*bc*sc*i*
alias:          pci:v00008086d00001581sv*sd*bc*sc*i*
alias:          pci:v00008086d00001580sv*sd*bc*sc*i*
alias:          pci:v00008086d0000157Fsv*sd*bc*sc*i*
alias:          pci:v00008086d00001574sv*sd*bc*sc*i*
alias:          pci:v00008086d00001572sv*sd*bc*sc*i*
depends:        configfs,ptp,vxlan
vermagic:       3.19.0-39-generic SMP mod_unload modversions
parm:           debug:Debug level (0=none,...,16=all) (int)
root@rccomdc3-066:~# uname -a
Linux rccomdc3-066 3.19.0-39-generic #44~14.04.1-Ubuntu SMP Wed Dec 2 10:00:35 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
root@rccomdc3-066:~# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS"
root@rccomdc3-066:~# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer3+4 (1)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: fast
Min links: 0
Aggregator selection policy (ad_select): stable
Active Aggregator Info:
Aggregator ID: 1
Number of ports: 2
Actor Key: 13
Partner Key: 33412
Partner Mac Address: 00:23:04:ee:be:33

Slave Interface: em1
MII Status: up
Speed: 10000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: f8:bc:12:08:c4:40
Aggregator ID: 1
Slave queue ID: 0

Slave Interface: em2
MII Status: up
Speed: 10000 Mbps
Duplex: full
Link Failure Count: 1
Permanent HW addr: f8:bc:12:08:c4:42
Aggregator ID: 1
Slave queue ID: 0

We've updated the kernel and the driver on the said server to no avial.  I've also removed and re-applied the configuration on the N5K side - wondering if anyone has run into this sort of issue before and has a fix? From the switch side there doesn't seem to be any additional configuration i require; (correct me if i'm wrong).  Any assistance would be appreciated.

thanks

Sheldon

2 Replies 2

Kirk J
Cisco Employee
Cisco Employee

Greetings.

I believe a had a similar case before with RHEL 6.5 and there was a RedHat KB that mentioned making sure the 'channel-group xyz mode active' was actually applied at the Port-channel Int itself and not just the members interfaces alone.

Thanks,

Kirk..

You can't apply the 'channel-group xyz mode active' at the Port-channel interface. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers