cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2227
Views
5
Helpful
5
Replies

Nexus 5548 - VM Traffic through Nexus failed

Nadav Katz
Level 1
Level 1

Hi guys,

I am having a Nexus switching problem in a data center.

VM traffic failed through the nexus switches, i run a ping test and the test is fail and back to success after few minutes, after a minute of success ping it is fail again.

Also when the nexus don't reach the tacacs this indicate us that we lose the VMs.

The issue affect the virtual servers and does not affect other servers. The virtual machine is VMWare with ESX and Vcenter.

Please look at the attach topology:

The issue happen in MST Region X.

We tried to disconnect MST Region Y and the issue is remain the same.

New Microsoft Visio Drawing.jpg

The 2 6500 switches in the bottom of the diagram runs GLBP for servers' default gateway.

Also, there is some downstream switches that connected to the 6500 switches and not apear in the diagram.

I found a workaround - If i configure on one of the 6500 in MST Region X on Port-channel 1 spanning-tree mst 0-1 cost 20 the issue is solved.

ESX server connectivity architecture:

6 nics. 2 for management and vmotion, 2 for NFS traffic, 2 for VM traffic.

Management and vmotion couple are configured as a team where one of the nics is primary for management and the second is primary for vmotion.

The NFS couple are configured the same.

The 2 nics configured for VM traffic are configured as active active.

Mode of connection: all connections are trunk.

Someone?

5 Replies 5

tiwang
Level 3
Level 3

hi again

are you sure that it is a nexus problem? - if the VM's are placed on the same esx host does it the also occur? Which VMWare version are yo running?

We run VMWare 5.1

if the VM's are placed on the same esx host the issue are remain, also the default gateway not reach the VM.

ok - then is it not related to a similar looking problem we had

Thanks anyway,

there is someone else that can help us?

Nadav Katz
Level 1
Level 1

Hi,

Finally, we found the problem.

We configure on the 6500's links - mtu 9216.

The VMs was disconnect cause the NFS generates jumbo frames.

Thanks a lot.