cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
626
Views
0
Helpful
4
Replies

Single Nexus 5548UP- FCoE configuration with multiple server ports

kuber.sharma
Level 1
Level 1

Hello Everyone,

I am new to Networking so please bear with me.

Here is some background information. We have a SINGLE Nexus 5548 UP switch to which we are connecting both the storage and the UCS C240 M3 servers (with CNA). Both the storage and server has 2 ports each going to this nexus switch.

We want to implement FCoE with this solution.

Below are the steps (for server ports) that I have followed to configure the nexus. But the port not logging into the SAN (no flogi) with the config.

***************************
Enable Features
***************************

config t
feature lacp
feature dot1x
feature interface-vlan
feature sshServer
feature npiv
end

******************************************
Confgure Ethernet Ports - Server 
******************************************

configure
interface ethernet 1/17
description To_UCS_rack_server_1_FCoE_port_1
switchport mode trunk
switchport trunk native vlan 6
switchport trunk allowed vlan 1,6
spanning-tree port type edge trunk
priority-flow-control mode on
no shutdown
end


configure
interface ethernet 1/18
description To_UCS_rack_server_1_FCoE_port_2
switchport mode trunk
switchport trunk native vlan 6
switchport trunk allowed vlan 1,6
spanning-tree port type edge trunk
priority-flow-control mode on
no shutdown
end

******************************************
Create VLAN
******************************************
configure
vlan 6
name FCOE_VLAN
fcoe vsan 6
end

******************************************
Setup FCoE QOS
******************************************

configure terminal
system qos
service-policy type qos input fcoe-default-in-policy 
service-policy type queuing input fcoe-default-in-policy 
service-policy type queuing output fcoe-default-out-policy 
service-policy type network-qos fcoe-default-nq-policy 
end

******************************************
Create vfc for Initiators (UCS Servers)
******************************************

configure
interface vfc 17
bind interface ethernet 1/17
switchport description virtual_fiber_channel_Server1_Port1
end

configure
interface vfc 18
bind interface ethernet 1/18
switchport description virtual_fiber_channel_Server1_Port2
end

******************************************
Adding vFC’s to VSAN
******************************************

configure
vsan database

vsan 6 interface vfc 17
vsan 6 interface vfc 18

******************************************
Create Zonesets and Zones
******************************************

configure

show flogi database vsan 6      ----> Do not see any pwwn here???
show fcns database vsan 6

 

Any help in the regard would be highly appreciated.

Cheers,
KS

 

4 Replies 4

Walter Dey
VIP Alumni
VIP Alumni

did you enable feature fcoe

http://www.4salesbyself.com/cisco-nexus-5500-configuring-fcoe.aspx

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli_rel_4_0_1a/CLIConfigurationGuide/fcoe.html

http://www.emc.com/collateral/hardware/technical-documentation/h10524-fcoe-case-studies-tb.pdf

Thanks for your reply.

Yes, I did enable the FCoE feature.

Question: If I have 3 servers, do I create a separate zone for each one of them? Or can I have one zone with the pWWN of all the servers?

Thanks in advance.

Cheers,

KS

Fixed the issue. "switchport trunk native vlan 6" was causing the issue. Maybe the storage and Servers were not configured with proper VLAN's. I removed the native vlan and everything logged in fine.

Any how I have configured a single zone with all 3 servers pWWN's. I know single initiator zoning is the way to go.

Can you please guide me if I can move these servers in their separate zones without any outages?  If it helps, all severs have 2 pWWN's. The current zoneset is active with that single zone.

Please let me know if you need any additional details.

Cheers,

KS

Hi KS

Excellent !

Regarding zoning, most (all) storage vendors prefer (recommend) single initiator - single target zoning. This requires more work, but might be better from the operational view.

I didn't do it, but you should be able to add this single initiator - single target zones to your existing zoneset, activating it, and see if it is ok (every pwwn has a * in front, which means a flogi has been done, and therefore there is no typo). Then in second step you remove the initial zone, and do again a zoneset activation.

Good luck !

Walter.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: