cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3573
Views
4
Helpful
7
Replies

Unable to migrate network to Nexus 1000V

APrassas7
Level 1
Level 1

Greetings

I'm unable to migrate the ESXi hosts' management network to the N1KV DS as network connectivity is lost when I commence the migration. When I start the migration I leave one pNIC assigned to the vSphere standard switch to maintain network connection and the other is assigned to the N1KV uplink port group. I use the N1KV latest version 4.2(1)SV1(5.1a).

I have successfully completed the installation of the N1KV on my vSphere environment, both the VSM (via the installer app) and the VEM (via the CLI). My vShpere deployment comprises of the following components:

2 ESXi hosts

N1KV VSM installed on host 1

vCenter server VM installed on host 2

Other VMs installed on both hosts

I have created and configured the following port groups in the N1KV DS:

Uplink

port-profile type ethernet VM_uplink

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 9-10

no shutdown

system vlan 9-10

state enabled

ESXi management

port-profile type vethernet ESXimgmt

vmware port-group

switchport mode trunk

switchport trunk allowed vlan 9-10

no shutdown

system vlan 9-10

state enabled

N1KV control-management-packet

port-profile type vethernet N1KVctrl

vmware port-group

switchport mode access

switchport access vlan 9

no shutdown

system vlan 9

state enabled

VM traffic

port-profile type vethernet VMnetwork

vmware port-group

switchport mode access

switchport access vlan 10

no shutdown

system vlan 10

state enabled

I enabled the above vlans before using them. After that I migrated as follows:

vCenter server VM

vNIC1 assigned to VMnetwork (vSphere standard switch)

vNIC2 assigned to ESXimgmt (N1KV DS)

N1KV VSM VM

vNIC1 assigned to VMnetwork (vSS)

vNIC2 assigned to N1KVctrl (N1KV DS)

vNIC3 assigned to ESXImgmt (N1KV DS)

All other VMs

all vNICs assigned to VMnetwork (N1KV DS)

I made the following observations that I would like to share:

  • Even though I set the allowed vlans in VM_uplink 9-10 in vSphere client VLAN ID has the value of VLAN access: 6-7. The same is happening with ESXimgmt which is also a mode trunk port prolfile.
  • I noticed that there is no assigned interface when I input port-profile show name <profile name> and as far as I've looked into it in the documentation i couldn't find the command

port-profile VM_uplink

type: Ethernet

description:

status: enabled

max-ports: 32

min-ports: 1

inherit:

config attributes:

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan 9-10

channel-group auto mode on mac-pinning

no shutdown

evaluated config attributes:

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan 9-10

channel-group auto mode on mac-pinning

no shutdown

assigned interfaces:

port-group: VM_uplink

system vlans: 9-10

capability l3control: no

capability iscsi-multipath: no

capability vxlan: no

capability l3-vn-service: no

port-profile role: none

port-binding: static

I've been through most of the documentation about port profiles, interfaces and L2 switching. What is the difference between a port profile, a port group and an interface? Do I need to assign an interface? Can you please help me find out the correct configuration for my network? I'd really like to understand how all this works and set it up myself.

Thank you in advance

1 Accepted Solution

Accepted Solutions