cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


815
Views
0
Helpful
3
Replies
Highlighted
Beginner

SG220-26 VLANS PFSense

Excuse the newbie in me, VLANS are new to me and I've decided to practice and learn a little bit more about them.

 

I have a PFSense router box that I made, I have 3 VLANS assigned to one of the interfaces, each with their own DHCP server.

 

VLAN 10 - 192.168.10.0/24

VLAN 20 - 192.168.20.0/24

VLAN 30- 192.168.30.0/24

 

From my PFSense I have a connection configured as a trunk port going to my SG220-26 switch.  If I configure lets say port 8 on my switch as an access port, my non-VLAN aware device will lose connection.  If I configure the port as a general port it connects but to the default VLAN of 1.....

 

I am at a loss with VLANs, I thought they would be simple to implement, but after a few days I am at the point of walking away.

 

I know this is only a lab network, but I just want to implement this and really need some help to get this thing working.

 

Ask questions and I will provide the details needed.

 

I appreciate your time in helping me.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi, Just as FYI this has been solved, the issue was because I was using Oracle Virtualbox and this app does not has VLAN support as another payed virtualizers like Hyper-V or VMware where you can create a Virtual switch and allow there traffic between VLANS on physical devices and interfaces.

 

View solution in original post

3 REPLIES 3
Highlighted
VIP Mentor

Make sure it was trunk configured ( default all the VLAN, or you need to allow only required VLAN in the trunk)

here is the example guide to configure PFSENSE with Cisco Switch.

http://mcisageek.net/?p=125

 

If you have still issue please share some screenshot and config to have look.

BB
*** Rate All Helpful Responses ***
Highlighted

Hi @balaji.bandi Thanks for your help, yep it is configured as a trunk port i'm connecting my pfsense server to the gi1 port,  i've checked the documentation however this switch(SG220) does not allow some cli commands.

 

Here you are my sw current config:

----------------------------

 

SwitchF77A9B#sh run

config-file-header
SwitchF77A9B
v1.0.0.17
CLI v1.0
@
!
!
!
!
username "cisco" secret encrypted ##########################################=
!
!
!
vlan 10
name "VLAN10"
vlan 20
name "VLAN20"
vlan 30
name "VLAN30"
voice vlan oui-table add 00:E0:BB 3COM
voice vlan oui-table add 00:03:6B Cisco
voice vlan oui-table add 00:E0:75 Veritel
voice vlan oui-table add 00:D0:1E Pingtel
voice vlan oui-table add 00:01:E3 Siemens
voice vlan oui-table add 00:60:B9 NEC/Philips
voice vlan oui-table add 00:0F:E2 H3C
voice vlan oui-table add 00:09:6E Avaya
!
!
!
!
spanning-tree mode rstp
spanning-tree mst configuration
name "3C:0E:23:F7:7A:9B"
!
!
!
!
!
!
!
!
!
ip ssh server
!
!
!
!
!
!
!
!
!
!
interface gi1
switchport trunk allowed vlan add 10,20,30
!
interface gi2
!
interface gi3
!
interface gi4
!
interface gi5
!
interface gi6
!
interface gi7
!
interface gi8
switchport mode access
switchport access vlan 10
spanning-tree portfast
!
interface gi9
!
interface gi10
!
interface gi11
!
interface gi12
!
interface gi13
!
interface gi14
switchport mode access
switchport access vlan 20
!
interface gi15
!
interface gi16
!
interface gi17
!
interface gi18
!
interface gi19
!
interface gi20
switchport mode access
switchport access vlan 30
!
interface gi21
!
interface gi22
!
interface gi23
!
interface gi24
!
interface gi25
!
interface gi26
!
!
!

SwitchF77A9B#

----------------------------------------------------------------

Please find attached some screenshots of my Pfsense current config.

 

Let me know in case you need further info.

 

Thanks for your time and help!

 

Regards,
Andrés

 

 

Highlighted

Hi, Just as FYI this has been solved, the issue was because I was using Oracle Virtualbox and this app does not has VLAN support as another payed virtualizers like Hyper-V or VMware where you can create a Virtual switch and allow there traffic between VLANS on physical devices and interfaces.

 

View solution in original post