cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1050
Views
5
Helpful
2
Replies

Can't ping using ROAS in Packet Tracer

kkct
Level 1
Level 1

Hi, I'm new, configuring a basic ROAS with 2 PCs, 1 switch and 1 router using Packet tracer, I can't ping from one PC to another PC, here is my configuration:

 

1. PC1 configuration (in vlan 10):

ip address: 192.168.1.1 255.255.255.0

 

2. PC2 configuration( in vlan 20) :

ip address: 192.168.1.2 255.255.255.0

 

3. Cisco 2960 Switch configuration:

interface f0/1

switchport access vlan 10

switchport mode access

 

interface f0/2

switchport access vlan 20

switchport mode access

 

interface g0/1

switchport mode trunk

 

4. Cisco 2901 Router configuration:

interface g0/1

ip address 192.168.1.3 255.255.255.0

no shutdown

 

interface g0/1.10

encapsulation dot1q 10

ip address 10.10.10.1 255.255.255.0

 

interface g0/1.20

encapsulation dot1q 20

ip address 20.20.20.1 255.255.255.0

 

I can't ping from PC1 to PC2 and vice versa. All the cables are well connected and interfaces up. Did I miss something?

1 Accepted Solution

Accepted Solutions

luis_cordova
VIP Alumni
VIP Alumni

Hi @kkct ,

 

Try making these changes:

 

1. PC1 configuration (in vlan 10):

ip address: 10.10.10.2 255.255.255.0

gateway: 10.10.10.1

 

2. PC2 configuration( in vlan 20) :

ip address: 20.20.20.2 255.255.255.0

gateway: 20.20.20.1

 

3. Cisco 2960 Switch configuration:

interface f0/1

switchport access vlan 10

switchport mode access

 

interface f0/2

switchport access vlan 20

switchport mode access

 

interface g0/1

switchport mode trunk

 

4. Cisco 2901 Router configuration:

interface g0/1

no ip address 

no shutdown

 

interface g0/1.10

encapsulation dot1q 10

ip address 10.10.10.1 255.255.255.0

 

interface g0/1.20

encapsulation dot1q 20

ip address 20.20.20.1 255.255.255.0

 

As you can see, the IP parameters of the vlan's pcs must correspond to the address configured in the subinterfaces.
Also, there should not be an IP address in the physical interface, but only in the subinterfaces.

 

Regards

 

View solution in original post

2 Replies 2

luis_cordova
VIP Alumni
VIP Alumni

Hi @kkct ,

 

Try making these changes:

 

1. PC1 configuration (in vlan 10):

ip address: 10.10.10.2 255.255.255.0

gateway: 10.10.10.1

 

2. PC2 configuration( in vlan 20) :

ip address: 20.20.20.2 255.255.255.0

gateway: 20.20.20.1

 

3. Cisco 2960 Switch configuration:

interface f0/1

switchport access vlan 10

switchport mode access

 

interface f0/2

switchport access vlan 20

switchport mode access

 

interface g0/1

switchport mode trunk

 

4. Cisco 2901 Router configuration:

interface g0/1

no ip address 

no shutdown

 

interface g0/1.10

encapsulation dot1q 10

ip address 10.10.10.1 255.255.255.0

 

interface g0/1.20

encapsulation dot1q 20

ip address 20.20.20.1 255.255.255.0

 

As you can see, the IP parameters of the vlan's pcs must correspond to the address configured in the subinterfaces.
Also, there should not be an IP address in the physical interface, but only in the subinterfaces.

 

Regards

 

Thank you very much!