Showing results for 
Search instead for 
Did you mean: 

SG300-28P - POE not correctly supported on all ports - possible firmware or hardware issue

Level 1
Level 1

So, I spent some time this weekend troubleshooting the issues I've had  with the new SG300-28P switch and POE to many of my devices in the  office.  As a recap, I cannot utilize all of the 24 POE ports on the switch  for POE purposes.  Really only every other port [with a few odd  combinations thrown in between]. In addition, the SG300-28P switch, on occasion, is sending POE to non-POE devices [e.g. my Ruckus Zone Director 1106].

Here are my POE devices [all 802.3 af-compliant]:

  • 3 Ruckus 7982 access points
  • 1 Pakedge access point
  • 2 home-automation controllers
  • 2 Polycom voip phones

I called Cisco support several times in regards to this problem, and they figured it was a hardware issue - a faulty switch.  So, Cisco sent me a replacement SG300-28P, which I  hooked up today.  The exact problem still occurs.  Default configuration  [fresh out of the box].  No way I can land, for example, the 3 Ruckus  7982 AP's on ports 1, 2, and 3 [or ports 1,13, and 2].  I have to put  them on ports 1, 3, and 5 in order for them to power up.  In addition, I  can't plug any other POE devices on the ports either between or below  them.   I had to skip another port bay.  This is very odd behavior!!   Two Cisco SG300-28P's in a row with the same problem.

However, I also had one of the new Cisco SG300-10P switches in my  possession for a recent project of ours.  I decided to hook up the same  POE devices to this switch.  ALL POE devices were recognized and  worked!  No need to skip a port.  And it didn't matter what device was  plugged in first or not.  I am now convinced that it is either a  hardware issue [bad power supply/transformer?] inside all of the  SG300-28P switches, or a firmware issue. 

Both of the SG300-28P switches were running firmware 1.1.2 [the  latest on Cisco's website].  So, I decided to install an older firmware  version on the SG300-28P switch that I'm returning [installed].   Here's what I found out.  I could then plug 2 POE devices [e.g. two  Ruckus AP's] in adjacent horizontal ports, but not three in a row.  In  addition, not all adjacent ports.  It's funky. For example, I could plug  an access point in ports 20 and 21, but not in 21 and 22.  No rhyme or  reason in how it worked.  And I still couldn't plug an access point in  adjacent vertical ports [e.g. ports 1 and 13].  BUT...

It's interesting that the same exact switch that would not initially  allow 2 horizontally-adjacent POE ports to be utilized WOULD allow 2  horizontally-adjacent POE ports to be utilized when running a different  firmware version.   It's also interesting to note that when plugged into  a "non-working" POE  port, the SG300-28P would actually make a small whining noise.  Very  subtle noise; I could hear it when approx. 1ft away from the switch.   The noise was not noticeable when ports were skipped [and POE actually  worked].  Therefore, I believe that Cisco has some SG300-28P firmware  bugs [at least in the last two versions of firmware] that is not truly  allowing all 24 ports to utilize POE correctly.  This problem does not  exist with the SG300-10P switch.

I'm really interested to hear what Cisco's reply and findings on this  matter would be.  And would welcome a reply from one of their senior  support team members/managers who could actually experiment with this,  too.   In addition, I'd like to know when they think a solution could be  created if it's firmware-related.  If hardware-related, I don't think  I'll be recommending any 28P switches in our projects.  Perhaps just the  regular SG300-28 with a separate SG300-10P.  It's a shame because the  SG300-28P is more of a bargain when compared to the two separate  components.

90 Replies 90


I plugged my APs in to ports 7, 8, 31, 32 (31 & 32 being directly below 7 & 8) and all powered up as expected.

Level 1
Level 1

Hello all,

I am currently in the middle of an installation with the exact same issue. I work for a Ruckus distributor and conduct 2-5 installations each week. We have recently (and successfully) installed combinations of Ruckus ZF7982 and ZF7372 APs with HP, Netvanta, Dell, and 3COM switches with no issues at all. I also have multiple customers that successfully use Cisco SG-300 10P and 28MPs. One of our 28 MP switches has 22 access points plugged into it at times totaling over 160 watts with no issues.

I just wanted to confirm this seems to be isolated to the SG-30028p and the newer Ruckus APs. However, these same devices seem to work with many other vendors with no issues. At what point do we assume it's Cisco?

Hi Mark,

Sorry to hear you're in the same boat.  I can confirm that it's any of the regular PoE 300 series switches including the 10P.  You have to use the MP (PoE+) versions to get around it unless you only put a few AP's staggered around.  It's also not as easy as just staggering them in every four ports (square) as we had an issue the other day with two on opposite ends of the switch.

Unfortunately the same goes for the 500 series switches and at this point I don't think they offer MP versions of those which is REALLY unfortunate.

Hope this helps.


Oh, and I forgot to mention that yes it is with the newer Ruckus AP's.  Apparently it has to do with a capacitor in the AP that Cisco's switches have trouble dealing with.  Though it is an issue found on this model switch with many 802.3at compatible AP's across vendors, I was told by a Ruckus engineer that they may change the capacitor as they've been receiving too many calls about the issue.  They are going to take action to try and fix it even though it's not really their issue.

Here's hoping because I love these switches and these issues have me looking elsewhere.

No, the problem is not isolated to SG300-28Ps.  My issue was orginally with a SG500-52P.  The tech I spoke with said the MP (max power) switches are wired differently from the regular P switches.  Since your not having issues with the SG300-10P or 28P, I guess thats not a hard rule for what will work and what won't.

Just out of curiousity, are the APs plugged into adjacent ports on the SG300-10P or 28P's?


i have problem in SG300 Poe 28 port

i have access point tp-link 5110 support poe when i bluged the device in switch the divece not powerd on


Level 1
Level 1

What about the SG300-10MP. This MP model is still only PoE and not PoE+ like the higher MP models? Will this have the same problem?

Actually, according to Cisco the SG300-10P will suffice although I've been using the 10MP just to be sure.  Some of the "advice" coming from Cisco regarding this issue hasn't exactly panned out for me, especially regarding to using the regular PoE switches and accounting for "spacing" the PoE devices out so I'm being extra cautious so as not to piss off any clients.  I've run multiple tests with various equipment and found the switches to be unreliable with any 802.3at compatible devices no matter what "spacing" you do.  For instance, even two devices on opposite ends of the switches will cause issues.  According to Cisco the transformers are grouped by every four ports in a square.  So in a 28 port switch the ports 1,2 and then the ones just below them will be a square.  Then 3,4 and the ones directly below those will be the next.  If you put one PoE device in each of those you're supposed to be fine but I've found issues still using it like that.  The MP versions fix the issue for sure but the 10 port versions are supposed to be immune to this issue and so far I would have to concur.

So in answer to your original question, yes the 10MP switches work just fine in this scenario, and without looking them up I'm pretty sure they are PoE+ models.  Apparently the transformers used in the 10 port switches were a different model than the ones used in the larger density switches.  You are good to go!

P.S. CISCO PLEASE ADD MP VERSIONS TO YOUR 500 SERIES SWITCHES SO WE AT LEAST HAVE THE OPTION!!!!!!!  I have to spec 300 series switches in jobs just because I have no reliable PoE support.  Sad.

The 10MP is not PoE+. It just supports regular PoE on all 8 ports simultaneously while the 10P only supports 4 ports simultaneously. This is why I suspect that the grouping on the 10MP is actually the same as the 28P etc.

No you have some bad info.....the 10P supports PoE on 8 ports.  I have done it myself numerous times.  Besides the datasheet confirms this as well:

Any combination of ports works but once the first four ports are  fully loaded the remaining ones won't activate. You might be using low  power devices (4-5 W) on the ports to get all of them working.

No sir, I can confirm that I have had 6 Ruckus ZoneFlex 7363's on one SG300-10P with no issues whatsoever.  Once again, I refer you to the datasheet and my own experience with these.  We have sold a LOT of these switches.  Maybe you have a bad one, otherwise I'm not sure where you are getting your data from.

The 10P is only 62 watts. You most certainly cannot connect 8x 15 W devices do it. It will only run 4x 15 W devices at a time. That's why the 10MP exists (It's 124 W).

You're talking about peak power.  Yes, you are correct that it cannot run more than 4 X 15 watt devices concurrently at peak.  However, this is not normally the case that all devices are always drawing full power and we've found the 10p's to work fine for our installations.  That said, since this issue arose with the 802.3at devices, as I said earlier we've only sold the 10MP's because I won't take the risk.  Maybe other issues could have come up but seeing as we're no longer testing the 10P's it's a moot point for us.  All I can say is what we have done in the past that worked.

So to your original question, the 10MP's don't suffer from the same issue as the other switches when it comes to compatibility with 802.3at devices.

I don't think the 10MP can run full power 802.3at devices as it's only PoE, not PoE+.