09-18-2014 02:36 AM
Hi,
I'm trying to add an additional vlan on to an SG300. I've created the vlan, but when I try and assign the vlan interface a static IP, I get an error message 'No more IP addresses could be added'.
I get that error from both CLI and GUI. Currently, there are only 2 other vlan's, and I have a test SG300 that has more vlan's and IP addresses for interfaces assigned.
Any idea what's going on?
Here's the relevant section from the config:
interface vlan 1
ip address 192.168.1.32 255.255.255.0
no ip address dhcp
!
interface vlan 10
name Main
ip address 192.168.42.254 255.255.255.0
ip dhcp relay enable
!
interface vlan 20
name "Building 3"
ip address 192.168.45.254 255.255.255.0
ip dhcp relay enable
!
interface vlan 30
name "Building 2"
!
It's vlan 30 I can't add the IP address to.
Cheers,
Donald.
09-18-2014 02:59 AM
Hi Donald,
There is no reason you should get this error. And I have not seen such an error before. It would be interesting to see full configuration file together with with the configuration steps taken and error message.
Regards,
Aleksandra
09-18-2014 03:31 AM
Configuration isn't particularly complex. Here it is with suitable bits removed.
sh running-config
config-file-header
xxxxxx
v1.3.7.18 / R750_NIK_1_35_647_358
CLI v1.0
set system mode router
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
vlan database
vlan 10,20,30
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp snooping
no ip dhcp snooping verify
ip dhcp snooping information option allowed-untrusted
arp timeout 300
ip dhcp relay address 192.168.42.6
ip dhcp relay enable
ip dhcp information option
bonjour interface range vlan 1
hostname xxxxxxx
username xxxxxx password encrypted xxxxxxxxx privilege 15
clock timezone " " 0 minutes 0
clock source sntp
no ip domain lookup
ip domain timeout 2
ip domain retry 1
!
interface vlan 1
ip address 192.168.1.32 255.255.255.0
no ip address dhcp
!
interface vlan 10
name Main
ip address 192.168.42.254 255.255.255.0
ip dhcp relay enable
!
interface vlan 20
name "Building 3"
ip address 192.168.45.254 255.255.255.0
ip dhcp relay enable
!
interface vlan 30
name "Building 2"
!
interface gigabitethernet1
switchport trunk native vlan 10
!
interface gigabitethernet2
switchport trunk native vlan 10
!
interface gigabitethernet3
switchport trunk native vlan 10
!
interface gigabitethernet4
switchport trunk native vlan 10
!
interface gigabitethernet5
switchport trunk native vlan 10
!
interface gigabitethernet6
switchport trunk native vlan 10
!
interface gigabitethernet7
switchport trunk native vlan 10
!
interface gigabitethernet8
switchport trunk native vlan 10
!
interface gigabitethernet9
switchport trunk native vlan 10
!
interface gigabitethernet10
switchport trunk native vlan 10
!
interface gigabitethernet11
switchport trunk native vlan 10
!
interface gigabitethernet12
switchport trunk native vlan 10
!
interface gigabitethernet13
switchport trunk native vlan 10
!
interface gigabitethernet14
switchport trunk native vlan 10
!
interface gigabitethernet15
switchport trunk native vlan 10
!
interface gigabitethernet16
switchport trunk native vlan 20
!
interface gigabitethernet17
switchport trunk native vlan 10
!
interface gigabitethernet18
switchport trunk native vlan 10
!
interface gigabitethernet19
switchport trunk native vlan 10
!
interface gigabitethernet20
switchport trunk native vlan 10
!
interface gigabitethernet21
switchport trunk native vlan 10
!
interface gigabitethernet22
switchport mode access
switchport access vlan 20
!
interface gigabitethernet23
switchport mode access
switchport access vlan 20
!
interface gigabitethernet24
switchport trunk native vlan 10
!
interface gigabitethernet25
switchport trunk native vlan 10
!
interface gigabitethernet26
switchport mode access
switchport access vlan 20
!
interface gigabitethernet27
switchport trunk native vlan 30
!
interface gigabitethernet28
switchport trunk native vlan 20
!
exit
ip default-gateway 192.168.42.11
And the error:
switchxxxxxx#conf
switchxxxxxx(config)#interface vlan 30
switchxxxxxx(config-if)#ip address 192.168.46.254 255.255.255.0
No more IP addresses could be added.
Cheers,
Donald.
09-18-2014 05:22 AM
Hi Daniel,
I added your configuration and even so managed successfully add IP address for VLAN 30, the same as yours.
But please note:
switchef113d(config)#do sh version
SW version 1.4.0.88 ( date 06-Aug-2014 time 16:55:55 )
Boot version 1.3.5.06 ( date 21-Jul-2013 time 15:12:10 )
HW version V01
Regards,
Aleksandra
09-18-2014 06:04 AM
Hi Aleksandra,
Here's what I get.
do sh version
SW version 1.3.7.18 ( date 12-Jan-2014 time 18:02:59 )
Boot version 1.1.0.6 ( date 11-May-2011 time 18:31:00 )
HW version V02
I see the same as you. On another switch, the config is fine and I can add an address. Typically, the one it is failing on is in a production environment. I will try a switch reboot out of business hours and see what happens. Failing that, I'll then do a firmware upgrade I guess.
Cheers,
Donald.
09-18-2014 06:21 AM
Hi Donald,
You definitely need to do boot code upgrade. Since version 1.3.5 boot code also was changed and those two should match as there pretty fundamental changes in file system. Reboot it is not good enough :-)
Regards,
Aleksandra
12-18-2014 04:32 AM
I am facing the same error, unfortunately I already upgraded both boot code and firmware prior to install and configure the switch.
On the other side I have a backup switch, I am going to make some tests on it.
I will try to reboot the main switch ASAP and make you know, however it's a weird situation, now I am in trouble with my customer.
12-22-2014 10:39 AM
Hi Matteo,
If this is urgent case I would recommend you to open ticket with Small Business Support team:
http://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html
so they can get more detailed information and investigate further.
Regards,
Aleksandra
12-22-2014 01:07 PM
I was able to change the configuration on the backup switch, so I downloaded the new configuration and uploaded it on the main switch, now I am waiting for the customer to reboot it during holidays.
06-07-2017 07:09 PM
Is there any limitation on the number of IP address?
I was trying to add IP address to each VLAN.
When I added around 50 IP addresses, it shows "No more IP addresses could be added."
switch4219a2(config)#interface vlan 748
switch4219a2(config-if)#ip address 172.18.1.193 /30
No more IP addresses could be added.
Please see the attachment for detail.
PS. The switch I'm using is SG300-28 28-Port Gigabit Managed Switch.
02-10-2015 08:25 AM
Facing just the same problem here. Also in a simple scenario.
COREVS#sh ver
SW version 1.4.0.88 ( date 06-Aug-2014 time 16:55:55 )
Boot version 1.3.5.06 ( date 21-Jul-2013 time 15:12:10 )
HW version V02
The only thing that dmackerracher and I have in common is the HW Version (v02), while your, Aleksandra Dargiel , is a V01.
Just upgraded the SW/Boot this weekend so I could bring up those ip addresses, but it seems to be a bug. I don't know. Unfortunately, I don't have a valid SMB support contract to open a ticket :(
03-22-2017 04:36 PM
Dear Aleksandra,
I having same issue like this, please advise below version details;
switch7796d6#sh ver
SW version 1.3.7.18 ( date 12-Jan-2014 time 18:02:59 )
Boot version 1.1.0.6 ( date 11-May-2011 time 18:31:00 )
HW version V02
switch7796d6#
May I know is there any possibility current configuration on the switch will be erase after applying the update?
Thank you.
Regards,
Saad
02-20-2015 12:31 PM
Hi dmackerracher, can u solve the problem??... i have the same dificult...!!!
FW 1.3.5.58
boot 1.1.0.6
appreciate your help... tnx..
Pablo
02-23-2015 07:19 AM
Hi Pablo,
Please try to upgrade boot code as well which for 300 series should be sx300_boot-13506.rfb and reboot the switch.
Regards,
Aleksandra
04-17-2017 05:13 PM
I had this problem too but found a workaround. You need to reboot the switch after making changes to the VLAN settings, then you can add the IP interface without the address error.
Upgrading the firmware only works once as it causes a reboot. You have to reboot after every VLAN change.
Cheers,
Brett.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide