cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1893
Views
0
Helpful
3
Replies
javdakker
Beginner

1900 series router not giving out IP adresses

Hi there,

I've got a problem with DHCP running on a cisco 1900 series router, 1921 to be precise. The Data VLAN works perfectly, i configured a ip helpder address

and its working. Problem tough is VLAN 20. This is the voice vlan. As u can see in the config below, this has been configured using VRRP and VRF for failover purposes. Anyone that can spot a problem in the configuration? I did more of these configurations, and they all worked fine, just not with this particular router!

As u will notice i deleted all the not needed to know information or i X'ed it!

Thanks in advance!

Jan-Aart

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CAR_LIC_BRO1_RTR001

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip vrf data

rd 6xxxx:10

route-target export 6xxxx:10

route-target import 6xxxx:10

!

ip vrf voice

rd 6xxxx:20

route-target export 6xxxx:20

route-target import 6xxxx:20

!

ip dhcp excluded-address vrf voice 10.0.42.1 10.0.42.100

ip dhcp excluded-address vrf voice 10.0.42.200 10.0.42.254

!

ip dhcp pool CAREAZ_VOICE_VRF_VOICE

vrf voice

network 10.0.42.0 255.255.255.0

default-router 10.0.42.254

lease infinite

!

!

no ip domain lookup

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1921/K9 sn xxxxxxxxxxxxxxx

!

!

username lagarde privilege 15 secret xxxxxxxxxxxxxxxxxxx

!

redundancy

!

!

!

!

!

track 1 interface GigabitEthernet0/0.6 line-protocol

!

track 2 ip route 0.0.0.0 0.0.0.0 reachability

ip vrf data

!

track 3 interface GigabitEthernet0/0.7 line-protocol

!

track 4 ip route 0.0.0.0 0.0.0.0 reachability

ip vrf voice

!

policy-map custom-shaper-50000Kbps

class class-default

  shape average 48200000

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description NAAR_FIBER_NTU

no ip address

duplex auto

speed auto

no keepalive

no cdp enable

!

interface GigabitEthernet0/0.6

description WAN_DATA_VLAN6

encapsulation dot1Q 6

ip vrf forwarding data

pppoe enable group global

pppoe-client dial-pool-number 1

no keepalive

no cdp enable

service-policy output custom-shaper-50000Kbps

!

interface GigabitEthernet0/0.7

description WAN_VOICE_VLAN7

bandwidth 1024

encapsulation dot1Q 7

ip vrf forwarding voice

pppoe enable group global

pppoe-client dial-pool-number 2

no keepalive

no cdp enable

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/0/0

description NAAR SWITCH_VOICE

switchport access vlan 20

no ip address

!

interface FastEthernet0/0/1

no ip address

!

interface FastEthernet0/0/2

no ip address

!

interface FastEthernet0/0/3

description NAAR SWITCH_DATA

no ip address

!

interface FastEthernet0/1/0

no ip address

!

interface FastEthernet0/1/1

no ip address

!

interface FastEthernet0/1/2

switchport access vlan 20

no ip address

duplex full

speed 100

!

interface FastEthernet0/1/3

switchport access vlan 20

no ip address

spanning-tree portfast

!

interface Vlan1

description DATA INTERNET

ip vrf forwarding data

ip address 10.32.36.2 255.255.255.0

ip helper-address 172.21.0.6

ip virtual-reassembly in

no ip route-cache

ip tcp adjust-mss 1452

vrrp 1 ip 10.32.36.1

vrrp 1 preempt delay minimum 20

vrrp 1 priority 121

vrrp 1 track 1 decrement 20

vrrp 1 track 2 decrement 20

!

interface Vlan20

description VOICE

ip vrf forwarding voice

ip address 10.0.42.251 255.255.255.0

no ip route-cache

vrrp 2 ip 10.0.42.254

vrrp 2 preempt delay minimum 20

vrrp 2 priority 121

vrrp 2 track 3 decrement 20

vrrp 2 track 4 decrement 20

!

interface Vlan100

description NATIVE WAN

no ip address

!

interface Dialer1

description DIALER_VOOR_VLAN_DATA

mtu 1492

ip vrf forwarding data

ip address negotiated

ip virtual-reassembly in

ip virtual-reassembly out

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxxxxxxxxxxx password xxxxxxxxxx

no cdp enable

!

interface Dialer2

description DIALER_VOOR_VLAN_VOICE

ip vrf forwarding voice

ip address negotiated

ip virtual-reassembly in

ip virtual-reassembly out

encapsulation ppp

dialer pool 2

dialer-group 2

ppp authentication pap callin

ppp pap sent-username xxxxxxxxxxxxx password xxxxxxxxxxxxxxx

no cdp enable

!

router bgp 6xxxx

bgp router-id vrf auto-assign

bgp log-neighbor-changes

!

address-family ipv4 vrf data

  network 10.32.36.0

  redistribute connected

  neighbor 172.31.255.68 remote-as 2yyyy

  neighbor 172.31.255.68 description Fiber_Main

  neighbor 172.31.255.68 password xxxxxxxxxxxxxxxxxxx

  neighbor 172.31.255.68 activate

  neighbor 172.31.255.68 weight 100

  neighbor 172.31.255.68 prefix-list announce_data out

exit-address-family

!

address-family ipv4 vrf voice

  network 10.0.42.0

  redistribute connected

  redistribute static

  neighbor 172.31.255.95 remote-as 2yyyy

  neighbor 172.31.255.95 description Fiber_Main_Voice

  neighbor 172.31.255.95 password xxxxxxxxxxxxxxxxxxxxxx

  neighbor 172.31.255.95 activate

  neighbor 172.31.255.95 weight 100

  neighbor 172.31.255.95 soft-reconfiguration inbound

  neighbor 172.31.255.95 prefix-list announce_voice out

exit-address-family

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

ip prefix-list announce_data description Uitgaand DATA subnet

ip prefix-list announce_data seq 5 permit 10.32.36.0/24 le 32

ip prefix-list announce_data seq 100 deny 0.0.0.0/0 le 32

!

ip prefix-list announce_voice description Uitgaand VOICE subnet

ip prefix-list announce_voice seq 5 permit 10.0.42.0/24 le 32

ip prefix-list announce_voice seq 100 deny 0.0.0.0/0 le 32

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

!

!

!

!

control-plane

!

!

!

line con 0

login local

line aux 0

login local

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login local

transport input all

!

scheduler allocate 20000 1000

end

Message was edited by: Jan-Aart vd Akker

3 REPLIES 3
Jeff Van Houten
Contributor

You have the svi configured, but have you added vlan 20 to the vlan database?

Sent from Cisco Technical Support iPad App

Julio Carvajal
Advisor

Hello Jan,

VRPP configuration looks good

DHCP configuration looks good

VRF setup looks good

Interface setup looks good

As Jeff mentioned I will check the layer 2 setup.

Any other question..Sure,,Just remember to rate all of the support answers.

Julio

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

Hi,

When i issue a Show ip int brief i see VLAN20 up up. So its working properly.

Weird thing is that when i configure a static ip on my laptop, and connect to a port on the router, that has switchport access vlan 20 configured, i can not ping the router address either... should be possible. I cant ping the vrrp ip address but neither can i ping the ip address on the vlan.

Any other suggestions?

Jan-Aart van den Akker