cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1152
Views
0
Helpful
4
Replies
Highlighted
Beginner

2610 Subinterface issue. Able to see cdp neighbours, but unable to ping them

I have a problem with my 2610 router. I have 2950 switch connected to the 2610 router using trunk connection. On the 2610 router when i assigned IP addres 192.168.0.1 to the interface e0/0 i am able to ping 192.168.0.2 -  my Vlan1 interface on the Switch. Then i deleted ip address from e0/0 interface on the router and assigned it to the subinterface e0/0.1 and immediatly i am unable to ping the e0/0.1. subinterface... but here is what i can see throuth the cdp neighbours command:

DR_Switch(config)#do show cdp neigh
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
DR_Router.dr.com
                 Fas 0/2            136           R       2610      Eth 0/0.1

DR_Switch#show cdp entry *
-------------------------
Device ID: DR_Router.dr.com
Entry address(es):
  IP address: 192.168.0.1
Platform: cisco 2610,  Capabilities: Router
Interface: FastEthernet0/2,  Port ID (outgoing port): Ethernet0/0.1
Holdtime : 139 sec

Version :
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JSX-M), Version 12.2(26c), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2007 by cisco Systems, Inc.
Compiled Mon 30-Jul-07 18:03 by ccai

advertisement version: 2
Duplex: half
Management address(es):

DR_Switch#

This is configuration of the interfaces...

(2610 router)

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.0.1 255.255.255.0

(2950 switch)

interface Vlan1

ip address 192.168.0.2 255.255.255.0

no ip route-cache

________________________________________________

Here is what i did to troubleshoot connection:

DR_Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

DR_Router(config)#in e0/0

DR_Router(config-if)#ip address 192.168.0.1 255.255.255.0

DR_Router#ping 192.168.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:

.!!!!

DR_Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
DR_Router(config)#in e0/0
DR_Router(config-if)#no ip address

DR_Router(config)#int e0/0.1

DR_Router(config-subif)#encapsulation dot1Q 1 native
DR_Router(config-subif)#ip address 192.168.0.1 255.255.255.0

DR_Router#ping 192.168.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.10, timeout is 2 seconds:

....

No result.... CAn you help me with this problem?

4 REPLIES 4
Rising star

2610 Subinterface issue. Able to see cdp neighbours, but unable

Hi Dmitriy,

Try removing the "native" command from the router configuration and ping.

conf t

int e0/0.1

no encapsulation dot1Q 1 native

encapsulation dot1Q 1

Regards

Najaf

Beginner

2610 Subinterface issue. Able to see cdp neighbours, but unable

additionally, make sure on your switch side, the interface(F0/2) must be set to trunk with "sw mo tru & sw tr en do"

Beginner

Re: 2610 Subinterface issue. Able to see cdp neighbours, but una

I've tried to remove native from encapsulation command and interface F0/2 on the switch is set up as a trunk (dot1Q). No success. I will try to remove vlan files from flash on the switch and the router later on today and create vlans again, maybe thats some sort of a glitch. I dont see any other reasons for it not to work.

Rising star

Re: 2610 Subinterface issue. Able to see cdp neighbours, but una

Hi Dmitriy,

Look at this

Your first Ping

DR_Router#ping 192.168.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:

.!!!!

Your second Ping

DR_Router(config-subif)#ip address 192.168.0.1 255.255.255.0

DR_Router#ping 192.168.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.10, timeout is 2 seconds:

....

For your second ping to 192.168.0.2 and ICMP request is send to 192.168.0.10...Check why is this happening on first place and that would nail the problem down

Regards

Najaf

Please rate when applicable or helpful !!!

CreatePlease to create content
Content for Community-Ad