cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

286
Views
0
Helpful
4
Replies
Beginner

2960-L Lanlite image and QoS - ref Auto-qos or QoS

I would like some guidance on QoS/Auto-QOS on the 2960-L.

Image is c2960l-universalk9-mz.152-6.E.bin

Feature Navigator says various QoS/Auto-QoS features are supported;
Auto QoS 1.5, Auto QoS - VoIP, Auto QoS VoIP enhancement.

I have a LanLite right-to-use license :-
Switch#sh lic right-to-use summ
License Name Type Period left
-------------------------------------------------------
Lanlite permanent Lifetime

 

Trying to use any 'auto qos' commands fails.

I can turn on 'mls qos' globally, and the only interface 

mls qos trust option is 'cos' - even if you enter after mls qos trust, it adds cos on the end.

Switch(config-if)#mls qos trust ?
cos cos keyword
<cr>

Switch(config-if)#mls qos trust
Switch(config-if)#
Switch(config-if)#do sh run int g 0/1
Building configuration...

Current configuration : 55 bytes
!
interface GigabitEthernet0/1
mls qos trust cos

 

In the config guide, www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_44_se/configuration/guide/scg1/swqos.html#wp1231112

it says -

Configuring Auto-QoS

Note To use auto-QoS, the switch must be running the LAN Base image.

 

Q * Is the Feature Navigator incorrect ??

 

In the Release Notes for my image www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960l/software/15-2_6_e/release_note/rn-1526e2-2960l.html

there is a note about LanLite+

Features of the Switch

The Catalyst 2960-L switch supports the LAN Lite+ feature set. This provides standard Layer 2 security and quality of service (QoS) features, and up to 256 active VLANs. The switch models have reduced functionality and scalability with entry level features in Layer 2, and support Virtual Stacking.

 

Q *  Are LANlite and LANLite+ different things, or the same ?

 

Ideally I would like to use auto qos to trust markings coming from elsewhere in the network on my uplinks, and to trust handsets on access ports on the switch.

Failing that I need to be able to match in a class-map used in a port policy, in order to match, ideally dscp ef, or even the IP subnet of phones. Neither of these is possible with the LAN Lite license.


Q * Do we need another license like LAN Base to be able to support QoS or even better, Auto-QoS

 

I know there are several q's here, but a number of documents suggest things that we don't see in front of us.

 

Ian

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: 2960-L Lanlite image and QoS - ref Auto-qos or QoS

Hi
yes the additional section is what you get with LanBase compared to the stripped down version of Lanlite, the OQS options, i still have a couple older 29s running lanbase support msl qos and auto qos as below

if your running lan lite i dont believe it has the option to upgraded to the lanbase just wont boot up , the reseller anyway that you would purchase the license should confirm either way, maybe its changed but you were never able to before

sh ver | i LAN
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(55)SE1, RELEASE SOFTWARE (fc1)
* 1 26 WS-C2960-24TC-L 12.2(55)SE1 C2960-LANBASEK9-M
#sh run int f0/6
Building configuration...

Current configuration : 239 bytes
!
interface FastEthernet0/6
switchport access vlan 164
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
ip dhcp snooping limit rate 7
4 REPLIES 4
VIP Mentor

Re: 2960-L Lanlite image and QoS - ref Auto-qos or QoS

Hi
you cant upgrade those switches , there lowest level switches and its hardware feature based for QOS

https://community.cisco.com/t5/switching/cisco-2960-tc-s-lan-lite-to-lan-base/td-p/2110914

• Additional QoS capabilities: The LAN Base IOS supports policing, class and policy maps, differentiated services code point (DSCP), AutoQoS, and configurable queue weights, buffers, and thresholds

• Higher network-level availability with features such as Flex Links and Link State Tracking •

Increased number of VLANs (256) and other enhancements such as IPv6 Host, MLD Snooping, LLDP-MED, RSPAN, MVR, DHCP Option 82, and IP SLA (responder)

Q. Can I upgrade or downgrade a Cisco Catalyst 2960 Switch between the LAN Base and LAN Lite IOS images?

A. No. Cisco Catalyst 2960 Series Switches cannot be upgraded from LAN Lite to LAN Base and cannot be downgraded from LAN Base to LAN Lite. http://tools.cisco.com/squish/16852
Highlighted
Beginner

Re: 2960-L Lanlite image and QoS - ref Auto-qos or QoS

Thanks Mark for the prompt response.

Checking your posted link there are details of -S products being LANLite and -L being LAN base.

my product id is : -

WS-C2960L-48PQ-LL

the front of my product says 2960-L but the cli definitely says LANLite as per the posted output.

 

Also the bullet points in your reply, were they relating to LAN Base ?

specifically :-

• Additional QoS capabilities: The LAN Base IOS supports policing, class and policy maps, differentiated services code point (DSCP), AutoQoS, and configurable queue weights, buffers, and thresholds

 

VIP Mentor

Re: 2960-L Lanlite image and QoS - ref Auto-qos or QoS

Hi
yes the additional section is what you get with LanBase compared to the stripped down version of Lanlite, the OQS options, i still have a couple older 29s running lanbase support msl qos and auto qos as below

if your running lan lite i dont believe it has the option to upgraded to the lanbase just wont boot up , the reseller anyway that you would purchase the license should confirm either way, maybe its changed but you were never able to before

sh ver | i LAN
Cisco IOS Software, C2960 Software (C2960-LANBASEK9-M), Version 12.2(55)SE1, RELEASE SOFTWARE (fc1)
* 1 26 WS-C2960-24TC-L 12.2(55)SE1 C2960-LANBASEK9-M
#sh run int f0/6
Building configuration...

Current configuration : 239 bytes
!
interface FastEthernet0/6
switchport access vlan 164
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust dscp
auto qos trust dscp
spanning-tree portfast
ip dhcp snooping limit rate 7
Beginner

Re: 2960-L Lanlite image and QoS - ref Auto-qos or QoS

@Mark Malone Thank you for the info, that demonstrates nicely that LAN Base would do the job.
It's a shame Feature Navigator is misleading -

Capture.JPG

 

Thanks again for your help.

 

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards