cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2801
Views
0
Helpful
5
Replies
Highlighted
Beginner

2960S Baud rate mistake

I have a Cisco 2960S-48LPS-L switch at my home (Network Engineer as job), and had it crash during a lightning strike next door.   When it booted back up the IOS was corrupt, so I downloaded the new(er) IOS and was getting ready to use Xmodem to get the IOS file on when I stumbled across an article stating you could manually set the baud rate to 115200 (no higher) to make things go faster.   Wouldn't you know it, I fat fingered it and now I can't read anything using my terminal emulator at any baud/duplex/parity or any other setting.

This happened almost 7 hours ago, and I have scoured Ciscos site and the internet, and it seems others have had this problem, but no fixes yet.   Since the 2960S doesn't have a "reset button", rather a mode button, there isn't anything I've been able to do.

Cisco said they would replace it within 10 days but no TAC support, but I can't wait that long since it's running our TV/Internet (V-lans) because my wife/son will probably kill me before then.

Since the switch is mine personally, I went ahead took the cover off looking for a CMOS type battery that maybe able to be removed....but no luck.

If anyone has any ideas, or has run across something like this before, I'm willing to pay (paypal) for any help that gets me back up and running soon!

If you want to handle this offline, I can send you my e-mail/phone#, or leave it here for anyone that's done it (or will).

I would greatly appreciate any help in this matter. 

Thanks

Shayne

Everyone's tags (5)
5 REPLIES 5
Highlighted
Hall of Fame Community Legend

2960S Baud rate mistake

From your console terminal, have you tried other baud rates?

If you finally found one, use the command "unset BAUD". 

Highlighted
Beginner

2960S Baud rate mistake

I've worked on this for almost 7 hours yesterday with different baud rates/parity settings etc.  Nothing works.

I'm looking for the magic button that will reset the switch to complete factory defaults.

S

Highlighted
Beginner

Re: 2960S Baud rate mistake

Hi
If you are connecting via terminal and had already change the speed you have two options the default 9600 or the changed 115000 try both.

Also in that model you have to enter to the terminal monitor via shift + ctrl + del keys. Keep the three key pressed since you power on for about 1 min, it's supposed to be 40 sec, try with both speeds.

Once you enter the term mon you can check the IOS version via dir flash:/
As I understand the problem is you cannot enter via serial, am I correct?

Highlighted
Beginner

Re: 2960S Baud rate mistake

What's happened was we had a bad storm yesterday and a "brown out".  When the switch started to boot back up, the IOS file was corrupted.

I used my serial cable to connect at 9600 baud, but since the switch wouldn't boot completely up, the only way to get a new IOS boot file on there was by using Xmodem.   I read that changing it to 115200 would make it go faster, but I must have fat fingered the "set BAUD 115200" command, and now everytime the switch boots into term mon, I get garbage on my screen.

I have changed it to every possible baud rate, tried holding down the "mode" button for 30 seconds to 10 minutes and even opening the case to see if there was a cmos type battery that would be holding the setting.

My problem is that the 2960S doesn't seem to have a complete reset button or a way of wiping everything like the 3560/3570 etc. switches do.

I know I'm not the only one that's had this problem before, but Cisco is willing to replace the switch (10-12 days) at no cost, but unwilling to help if there is a work around.  For now, I'm using my old 3550 switch, but miss the 1G ports and PoE.

I wish there were CCIE's or Cisco Tech's that looked at these every once in awhile and maybe come across this and say a yes or no if it can be done.

BTW, I tried your suggestion and it didn't work either.   I think I'm going to have to return it and just wait it out unless someone that's actually had this problem happens to read it and knows a work around. 

Thanks for the suggestion!

Shayne

Highlighted
Hall of Fame Community Legend

2960S Baud rate mistake

Try a different computer.

CreatePlease to create content
Content for Community-Ad