We currently have 3725 router with an ip address of 172.16.1.1 and a 3750 switch with an ip address of 172.16.1.9. Our goal here is to use the 3750 as a router and remove the 3725. Here is a partial current config:
3725
====
!
interface FastEthernet0/0
description S/N FTX1026A5XW
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description Network
encapsulation dot1Q 1 native
ip address 172.16.2.1 255.255.255.0 secondary
ip address 172.16.1.1 255.255.255.0
ip helper-address 10.223.250.60
interface FastEthernet0/0.3
description Student Vlan
encapsulation dot1Q 3
ip address 10.2.3.1 255.255.255.0
ip helper-address 10.223.250.60
!
!
router eigrp 64
network 10.0.0.0
network 172.26.0.0
no auto-summary
!
3750
====
!
interface GigabitEthernet1/0/12
description UL from Router
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast trunk
!
interface Vlan1
ip address 172.16.1.9 255.255.255.0
!
ip default-gateway 172.16.1.1
!
What we want to do is some initial prep work on the 3750 (prior to removing the 3725). Here are the statments that we are thinking about adding to the current 3750 config:
3750
====
!
ip routing
!
router eigrp 64
network 10.0.0.0
network 172.16.0.0
no auto-summary
!
By adding the above to the current 3750 config, will this cause any issues (prior to removing the 3725)? Do we need to remove the ip default-gateway statement? Also, we will change the the address on the 3750 after we remove the 3725 to 172.16.1.1 as well as add Vlan3.