cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
11424
Views
0
Helpful
35
Replies

3750x doesn't boot after upgrade to version15

Due to a problem with POE+ i have tried to upgrade the IOS to Version15.0.2SE2,  from 12.2.58. unfortunatly the Switch doesn't boot up anymore. It starts to decompress and install the IOS 2 Times, after the Second try it displays "unable to boot" and the switch goes in Bootloader-mode.

When i look at the version i See that bootloader is still the old version 12.2.58.

It seems that the bootloader doesn't geht upgraded and that's why the Switch can't Boot the new Image.

Is there anything i can do to Upgrade the bootloader seperatly?

It's a 3750X48PF-S

Many thanks

Andy

35 REPLIES 35
Leo Laohoo
VIP Community Legend

Bootloader is automatically upgraded when you upgrade the IOS.  Now, I believe what you are experiencing is the "heart attack event" when the bootloader is being upgraded by the IOS.  This can take about 45 heart-stopping minutes, hence the term "heart attack event".

Thanks for the reply, but i don't think so.

Here is the output from the boot-process:

File "flash:/c3750e-ipbasek9-mz.150-2.SE2/c3750e-ipbasek9-mz.150-2.SE2.bin" uncompressed and installed, entry point: 0x3000

executing...

Boot process failed...

switch:
switch:

And the Bootloader shows still the old version:

switch: ver

C3750E Boot Loader (C3750X-HBOOT-M) Version 12.2(58r)SE, RELEASE SOFTWARE (fc1)

Compiled Tue 26-Apr-11 06:59 by abhakat

switch:

Best regards

Andy

Hi Andy,

It seems the flash memory is corrupted as it can't be accessed from the switch: 
prompt nor initialized at boot up.

Kindly raise the RMA to get the replacement switch.

HTH

Regards

Inayath

I also thought that there is a hardware problem but it's the second switch showing the exact same problem.

Hi Andreas,

So probably the other switch might have the same issue.

Regards

Inayath

hi.everyone ,i also have same problem .

File "flash:/c3750e-universalk9-mz.152-4.E1.bin" uncompressed and installed, entry point: 0x3000
executing...
Boot process failed...

so how to resolve this problem ,here have some result ?

Boot process failed...

The IOS you've loaded into the switch is corrupted.

Download again from the Cisco website and, before you do anything, compare the MD5 hash of the file against the one in the Cisco website.  Make sure they are a match.

Next, find a spare USB flash thumb drive.  Doesn't matter what size, up to 16 Gb will be fine.  Format this USB thumb drive with FAT16 standard.  Copy the IOS into the thumb drive and insert into the 3750X.

From the "switch:" prompt, use the command "boot usbflash0:IOS.bin".

NOTE:  I've noticed you're trying to boot 15.0(2)SE2.  Just want to pass a word of caution as there have been some people who've noticed CPU spikes when running this version.

Your IOS is most likely to be corrupted as Leo mentioned. I dont believe two switches would have gone faulty out of the blue (although its entirely possible)
Please verify MD5 checksum for the image from cisco's site from where you downloaded your IOS and compare with what you have.

You can use this utility http://www.georgejopling.co.uk/md5check/md5check.html

If the value is different, then it's corrupted.
Please try to load a clean IOS image on there.

Hope this helps

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Yesterday I ran into exactly the same issue.

MD5sum of the FW15 images on flash (I left them there) are a 100% match with the MD5sums supplied by Cisco.

I ended up revering to 12.2-58.SE2, which works without a sweat. Download from the same product page, so i'm quite sure I tried the right FW 15 image (c3750e-ipbasek9-mz.150-2.SE2.bin).

 
ansonleekh
Beginner

Hi Andreas,

I ran into this issue last night and in fact now I am still having this issue on my WS-C3750X-48T-S.

When I am in the ROMMON mode, I am able to boot into 12.2-58.SE2 but not those version 15. This is very weird.

Besides I am very sure that I have the correct and legitimate version 15 IOS.

Are you able to find the solution? If yes, it would be useful if you could share the finding with us.

Thank you in advance.

Hi,

it turned out that we've received grey-market equipment. I am in europe and the switches are built for North-America.

Seems like the boot-roms are different.

We are getting all switches replaced now.

Hi Andreas,

Thank you for your reply, appreciate it.

How do you found out that your switches were from other region / using different boot-roms?

Does this can be checked from the switch itself?

I have no more idea on what is the reason my switch cannot boot up into version 15 but have 100% success on version 12

That was a big problem, i guess the only way is to give the serial-numbers to your cisco-account manager..