cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
9160
Views
15
Helpful
4
Replies
Tuan Nguyen
Beginner

3850 doesn't boot automatically, even after boot system switch all flash:packages.conf in the configuration.

3850 doesn't boot automatically, even after boot system switch all flash:packages.conf in the configuration.

After upgrading to the latest code.

 

The system is not configured to boot automatically.  The

following command will finish loading the operating system

software:
 
    boot
 
 

switch: boot

Even with boot system switch all flash:packages.conf in the configuration and save

!
boot-start-marker
boot system switch all flash:packages.conf
boot-end-marker
 

 

All input are welcomed and appreciated.

Thanks

 

4 REPLIES 4
tprivett
Cisco Employee

The reason that your switch is not booting automatically, even though you have the boot statement configured, is most likely your config-register.

Check the output of the 'show version' command, and at the very bottom you should see something like this:

Configuration register is 0x102

If your value is something other than 0x102 change it, from configuration mode, using the command 'config-register 0x102'

My config register is configured as 0x102 and I am still experiencing the same issue as the original post.  Any other ideas?

 

Thank you,

Joe

Hello.

 

When in bootloader ( switch:  ) you have to set MANUAL_BOOT=no

after that the switch boots automatically from the bootvar which is entered.

I am having the same issue, but only after a diagnostics test.  It boots correctly after a power failure, but not after i use the command line.  If i use the command line: switch#reload; it says the switch is not enabled for automatic booting.  However I checked the settings, which are:

config reg 0x102

boot variable=flash:packages.conf

manual boot=no

enable break=no

boot mode=device

ipxe timeout=0

 

Please advise.  Is this switch a failure and needed to be returned?