cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
694
Views
20
Helpful
4
Replies

3850 stack with ISR4431 etherchannel configuration

Hi team, 

 

Just wanted to ask you how can I make an etherchannel between the 2 stack cisco switches 3850 and the ISR4431/K9?

 

Im kind of confused I know that in some other post it is possible but never saw any config and Im not fully aware of how to mix both things up, 

 

is it layer 2 or layer 3 that I need to configure in both ends?

 

anyone has a sample config? I wish I could test in packet tracert or something, but if someone has already made it, can you provide me with some ideas?

 

attached you will find the topology in which I want to have the router with its loopback 1.1.1.1 reachable from the other side of the stack where I have connected the core switches to the stack layer 2 switches. 

 

but Im not really sure how it will go, can the following work?

 

switch:

int gig1/0/2

channel-group 1 mode on
switchport mode trunk

exit

 

int gig2/0/2

channel-group 1 mode on
switchport mode trunk

exit

 

router config:

interface port-channel1
ip address 10.10.10.1 255.255.255.0
exit

 

interface GigabitEthernet0/0/01- 0/0/2
channel-group 1
exit

4 Replies 4

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Hi,

Yes, you can create a Po between the switches and the router (see link for an example). It has to be layer-3 Po, as the router does not support VLANs. So, your config example looks correct.

https://www.cisco.com/c/dam/en/us/products/collateral/routers/3800-series-integrated-services-routers-isr/prod_white_paper0900aecd806f698a.pdf

 

Are the 3850 switches going to serve as layer-3 (core)? If that is the case, you want to terminate all your vlans on the core, and then use a layer-3 Po to connect to the router. If this is a small network, you can simply use static routes between the core 3850s and the router.

HTH

thank you Reza, 

 

I now start to understand. Yes, however, actually, the final set will be the Core multilayer ----> FW--->3850 stack----> Router ISR

so basically, when you say my config looks correct, are you referring only to the router portion? 

 

Cause the switch is a L2 port channel example, 

 

Thats where I get confused, if switch side should be Layer 3 or Layer 2, and in the Router ISR side, definitely should be Layer 3

 

 

 

 

I apologize. I should have said that you also need an IP on the switch side. So, the Portchannel needs to have an IP on each side (layer-3).

example for the switch

interface port-channel1
ip address 10.10.10.2 255.255.255.0
exit

And one more thing, the switch side does not need to be a trunk port. Simply an access port

switch:

int gig1/0/2

channel-group 1 mode on
switchport mode access

switch port access vlan xx

exit

 

int gig2/0/2

channel-group 1 mode on
switchport mode access

switch port access vlan xx

 

exit

HTH

Got it, thank you so much for your response, let me try to make it and I will post how it went, 

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers