cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
340
Views
0
Helpful
1
Replies
Highlighted
Beginner

3G router 887G-K9 chat-script problem

Hello

I have a Cisco 887G-K9 with version 15.1-4 3G router,  I set up the router following the guidelines of cisco, but i cant stablish a succesfull connections, the router have the interface cellular 0 up with good RSSI, but when i force traffic to initiate the connexion the following error says

"line reset by Async Dialer"

I have attached my running-configuration( with sensitive info changed)   show cell 0 all output command and the error when chat-script initates the conection

Anybody could give me help?
Cheers!!

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: 3G router 887G-K9 chat-script problem

Hello,

 

a few things were missing in your config, I have made some changes/additions (marked in bold). Also, try the different chat scripts, as well as encapsulation slip for the cellular interface:

 

hostname 3G_ROUTER
!
boot-start-marker
boot-end-marker
!
logging buffered 32000
enable secret 5 $1$D4wB$8Z6Yx5kdOrsHHGAJjTUli.
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
ip source-route
!
ip cef
ip domain name bme
no ipv6 cef
!
multilink bundle-name authenticated
chat-script gsm "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"
chat-script gsm "" "AT!CALL " TIMEOUT 60 "OK"
chat-script gsm “” “AT!SCACT=1,1” TIMEOUT 60 “OK”
license udi pid CISCO887G-K9 sn FTX102085QU
!
controller Cellular 0
!
ip ssh version 1
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 196
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp/slip
load-interval 60
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive

!
interface Vlan1
ip address 10.14.24.38 255.255.255.0
ip nat inside
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
!
ip route 0.0.0.0 0.0.0.0 Cellular0
ip route 10.144.0.0 255.255.0.0 10.144.24.254
!
access-list 1 permit 10.14.24.0 0.0.0.255
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
line aux 0
line 3
exec-timeout 0 0
script dialer gsm
modem InOut
no exec
transport input all
rxspeed 7200000
txspeed 5760000
line vty 0 4
password admin
login
transport input all
!
end

1 REPLY 1
VIP Mentor

Re: 3G router 887G-K9 chat-script problem

Hello,

 

a few things were missing in your config, I have made some changes/additions (marked in bold). Also, try the different chat scripts, as well as encapsulation slip for the cellular interface:

 

hostname 3G_ROUTER
!
boot-start-marker
boot-end-marker
!
logging buffered 32000
enable secret 5 $1$D4wB$8Z6Yx5kdOrsHHGAJjTUli.
!
no aaa new-model
!
memory-size iomem 10
crypto pki token default removal timeout 0
!
ip source-route
!
ip cef
ip domain name bme
no ipv6 cef
!
multilink bundle-name authenticated
chat-script gsm "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"
chat-script gsm "" "AT!CALL " TIMEOUT 60 "OK"
chat-script gsm “” “AT!SCACT=1,1” TIMEOUT 60 “OK”
license udi pid CISCO887G-K9 sn FTX102085QU
!
controller Cellular 0
!
ip ssh version 1
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 196
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp/slip
load-interval 60
dialer in-band
dialer string gsm
dialer-group 1
async mode interactive

!
interface Vlan1
ip address 10.14.24.38 255.255.255.0
ip nat inside
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
!
ip route 0.0.0.0 0.0.0.0 Cellular0
ip route 10.144.0.0 255.255.0.0 10.144.24.254
!
access-list 1 permit 10.14.24.0 0.0.0.255
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
line aux 0
line 3
exec-timeout 0 0
script dialer gsm
modem InOut
no exec
transport input all
rxspeed 7200000
txspeed 5760000
line vty 0 4
password admin
login
transport input all
!
end

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards