09-14-2011 11:54 AM - edited 03-07-2019 02:13 AM
I am looking to impliment a different type of 802.1x and need help.
I will like to give everyone access to vlan 50 if they are not authorized. However, if they are authorized, they will get vlan 75.
Can this be done?
09-14-2011 12:02 PM
Hello,
Yes, that is possible. Cisco 802.1X implementation on Catalyst switches recognizes the following types of VLANs:
What exact Catalyst type and IOS version are you using? The commands have changed recently so to be able to provide you with a configuration example that would work for you, it would be very helpful to know what switch and IOS you are currently using.
Best regards,
Peter
09-14-2011 12:16 PM
I am currently using 2950s with 12.1 IOS for production. I also have a 3560g with 12.2 IOS.
Is the config done on the VLAN or the switchport?
Thank you
09-14-2011 12:39 PM
Hello,
Regarding the 3560G, I would need to know the precise IOS version. The AAA and 802.1X commands have changed somewhere around 12.2(50)SE.
The configuration is done on a per-switchport basis. For example, the 2950 would be configured as follows:
dot1x system-auth-control
!
interface FastEthernet0/1
switchport mode access
dot1x port-control auto
switchport access vlan 75
dot1x auth-fail vlan 50
dot1x guest-vlan 50
Best regards,
Peter
09-14-2011 12:41 PM
its 12.2(58)SE1
09-14-2011 12:42 PM
The 2950 however is 12.1(22)EA14
09-14-2011 12:51 PM
Hello,
Alright, the configuration for 3560G would be as follows:
dot1x system-auth-control
!
interface GigabitEthernet0/1
switchport mode access
switchport access vlan 75
authentication port-control auto
authentication event no-response action authorize vlan 50
authentication event fail action authorize vlan 50
Please let me know if these settings worked for you.
Best regards,
Peter
09-14-2011 12:58 PM
how do you configure it to look for the RADIUS server for authentication?
09-14-2011 01:08 PM
Hello,
I assumed you are already familiar with the basic 802.1X config. Sorry.
This should do the trick:
aaa new-model
aaa authentication dot1x default group radius
radius-server host X.X.X.X auth-port 1812 acct-port 1813 key SECRET
!
dot1x system-auth-control
!
interface FastEthernet0/1
[ ... use the interface config I suggested earlier ... ]
Replace the X.X.X.X with the IP address of your RADIUS server, and the SECRET with the shared secret between your switch and the RADIUS server. You should verify that your switch can ping the RADIUS server before configuring the 802.1X authentication (you will obviously need to have a proper interface VLAN created and the default gateway set). Also, activating the "aaa new-model" will change the settings for authentication on your console and VTY lines so back up your configuration before making these changes. It may be necessary to perform minor tweaking.
Best regards,
Peter
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide