cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
487
Views
0
Helpful
1
Replies
Highlighted
Beginner

877W, 1483 ADSL, Multiple Static IPs, NAT, Help!!

Good afternoon.  I posted this regarding an 857W many month ago and was never able to get it to work; in fact, I was told it would not work due to the limitation on VLANs, so I stopped trying.  I now own an 877W, and have been told this should work.  I have ADSL with 8 static IP addresses (non-congtiguous - go figure), served via RFC-1483 bridging.  That means no username or password or anything - just a negotiation process.  I have been operating for a long time in pure bridge mode, and everything does work, however, it seems a waste for this unit to sit there and just bridge the connection.  I would like to actually get it to do some routing!  Nothing I have tried works, and none of the tutorials on integrated bridging and routing seem to work either.  Here is the scenario:

Available WAN IP addresses: 11.22.33.99, 11.22.33.166 - 11.22.33.172

Gateway: 11.22.33.1

What I would like to do is hold the 11.22.33.99 address at the 877 and use it for DHCP, WLan, IPv6 tunnel endpoint, etc.  I would then want the other addresses (166-172) bridged over the FastEthernet interface to do what I want with them.  I'm not sure how to make this work.  For starters, here is my working configuration for pure RFC-1483 bridging and DHCP handling of the LAN:

#show run
Building configuration...

Current configuration : 1640 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname whatever
!
boot-start-marker
boot-end-marker
!
enable secret 5 whatever
!
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
!
!
dot11 syslog
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.200
ip dhcp excluded-address 192.168.1.250 192.168.1.255
!
ip dhcp pool dhcp1
   network 192.168.1.0 255.255.255.0
   dns-server 192.168.1.100
   default-router 192.168.1.100
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
username whatever
!
!
archive
log config
  hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
pvc 0/35
  encapsulation aal5snap
!
dsl operating-mode auto
bridge-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.1.1 255.255.255.0
ip virtual-reassembly
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end

1 REPLY 1
Highlighted
Hall of Fame Master

The additional addresses are not to be bridged. You can use static NAT for them, and that will give you the same identical results.

Thanks, Paolo.

Content for Community-Ad