cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
492
Views
0
Helpful
1
Replies

access to the router from 8 port switch module

alex goshtaei
Beginner
Beginner

Hi All,

I have 2821 router with 8 port switch module, I am trying to access the router from switch module by connecting Gi 0/0 port from chassis to the port fa 0/1/7 in switch module, then conenct port fa 0/1/8 from swich module to the 3750 switch, but I can't access to the router and it seems there is no IP connectivity.

here is my config:

router:

                  

interface Loopback0

ip address 177.1.254.1 255.255.255.255

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed 100

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.15.120 255.255.255.0

!

interface GigabitEthernet0/0.11

encapsulation dot1Q 11

ip address 177.1.11.1 255.255.255.0

!

interface GigabitEthernet0/0.12

encapsulation dot1Q 12

ip address 177.1.12.1 255.255.255.0

! This port is connected to Gi 0/0

interface FastEthernet0/1/7
switchport mode trunk
switch tr native vlan 1

!This port is connected to 3750 switch
interface FastEthernet0/1/8
switchport mode trunk
switch tr native vlan 1

Switch:

!This port is connected to 0/1/8

interface FastEthernet0/23

switchport trunk encapsulation dot1q

switchport mode trunk

switch tr native vlan 1

end

any suggestion would be very appreciated.

thanks

Alex

1 Reply 1

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello Alex,

you should be able to use an SVI Vlan interface associated to Vlan 1 on the ports of the ethernet switch module.

something like

interface vlan1

ip address 192.168.15.120 255.255.255.0

There is an internal link between the router and the etherswitch module, so you don't need to waste a precious router port like g0/0 to connect to the etherswitch module.

see

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_configuration_example09186a00808066b8.shtml

Hope to help

Giuseppe

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers