12-15-2011 06:30 AM - edited 03-07-2019 03:55 AM
Dears,
I want to load balance between two webservers using ACE10 working in bridging mode, but when putting the VIP in the url i'm getting page not found, tried many configurations but didn't work, here is the latest one
logging enable
logging buffered 7
access-list ALL line 8 extended permit ip any any
rserver host test1
ip address 172.24.1.32
inservice
rserver host test2
ip address 172.24.1.33
inservice
serverfarm host ourtest
predictor leastconns
rserver test1
inservice
rserver test2
inservice
sticky http-header Host GROUP4
header offset 999 length 1000
timeout 720
timeout activeconns
replicate sticky
serverfarm ourtest
class-map type http loadbalance match-any L7CLASS
10 match http header Host header-value ".*"
class-map match-any VS_WEB2
10 match virtual-address 172.24.1.82 tcp eq www
policy-map type management first-match remote-access
class class-default
permit
policy-map type loadbalance first-match L7POLICY
class L7CLASS
sticky-serverfarm GROUP4
insert-http Host header-value "*"
policy-map multi-match HTTP_MULTI_MATCH
class VS_WEB2
loadbalance policy L7POLICY
interface vlan 650
bridge-group 1
access-group input ALL
no shutdown
interface vlan 801
bridge-group 1
access-group input ALL
service-policy input HTTP_MULTI_MATCH
no shutdown
interface bvi 1
ip address 172.24.1.83 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 172.24.1.1
12-15-2011 08:58 AM
I tried to configure it as in the below link, but it didn't work
hope somebody could help.
12-15-2011 10:53 AM
You should move this question to Application Networking Forum.
However based on link given seems to be missing -
service-policy input remote-access on server facing vlan.
Thanks
Ajay
12-15-2011 11:12 AM
Hi
In your
policy-map multi-match HTTP_MULTI_MATCH
class VS_WEB2
loadbalance policy L7POLICY
LOADBALANCE VIP INSERVICE
Is missing
Sent from Cisco Technical Support iPhone App
12-18-2011 06:15 AM
below the updated configuration, it didn't work until i added the redirct configuration, but i doubt that this is correct, since this will not work for other pages..
---------------------------------------------------------
Generating configuration....
logging enable
logging buffered 3
access-list ALL line 8 extended permit ip any any
probe http test
passdetect interval 5
expect status 100 500
rserver host test1
ip address 172.24.1.32
inservice
rserver redirect test1r
webhost-redirection http://172.24.1.33/sites/residential/English/Pages/
inservice
rserver host test2
ip address 172.24.1.33
inservice
rserver redirect test2r
webhost-redirection http://172.24.1.32/sites/residential/English/Pages/
inservice
serverfarm host ourtest
predictor leastconns
probe test
rserver test1
inservice
rserver test2
inservice
serverfarm redirect test
rserver test1r
inservice
rserver test2r
inservice
class-map type http loadbalance match-all HTTP
2 match http url /sites/residential/English/Pages.*
class-map match-any VS_WEB2
10 match virtual-address 172.24.1.82 255.255.255.0 tcp eq www
policy-map type management first-match remote-access
class class-default
permit
policy-map type loadbalance first-match HTTP_LB
class HTTP
serverfarm test
class class-default
serverfarm ourtest
policy-map multi-match HTTP_MULTI_MATCH
class VS_WEB2
loadbalance vip inservice
loadbalance policy HTTP_LB
loadbalance vip icmp-reply
interface vlan 650
bridge-group 1
no normalization
access-group input ALL
no shutdown
interface vlan 801
bridge-group 1
no normalization
access-group input ALL
service-policy input HTTP_MULTI_MATCH
no shutdown
interface bvi 1
ip address 172.24.1.83 255.255.255.0
no shutdown
ip route 0.0.0.0 0.0.0.0 172.24.1.1
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide