cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1080
Views
15
Helpful
12
Replies

Adding a VLan

rkovelman
Level 1
Level 1

Hi All,

I need to add a new vlan to my 1841 and as of now the two vlans I have are essentially tied to the two interfaces on the device.  Is there a way I can add another vlan with out having it tied to an interface as there are no more?  Below is the config I have currently for the interfaces:

!

interface FastEthernet0/0

description Data Network

ip address 192.168.xx.1 255.255.255.0

speed 100

full-duplex

no mop enabled

!

interface FastEthernet0/1

description Voice Network

ip address 192.168.xx.1 255.255.255.0

speed 100

full-duplex

!

ip default-network 192.168.20.0

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.20.251

!

Is this possible? I will need to run a DHCP server for that vlan on the 1841 as well.

Thank you

12 Replies 12

Collin Clark
VIP Alumni
VIP Alumni

You bet it is. What you want to do is trunk the router interface to your connected switch. You would create subinterfaces for each VLAN you want to route between.

interface GigabitEthernet0/0

description Trunk Interface

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

description Native VLAN Interface - Dont use

encapsulation dot1Q 1 native

!

interface GigabitEthernet0/0.3

description Voice VLAN

encapsulation dot1Q 3

ip address 10.36.8.11 255.255.248.0

!

interface GigabitEthernet0/0.4

encapsulation dot1Q 4

ip address 10.36.200.12 255.255.255.0

!

https://learningnetwork.cisco.com/thread/2401
      

Thanks for the info.

OR would you suggest I just open the subnet from 255.255.255.0 to some that allows for more IP's?  I am going to assume that is the quicker and dirtier method that doing the vlans.

You can do that but you'll need to change the subnet masks on all your devices. That may end up being more work.

Now that you say that Collin you are right. 

With that said can I just do vlans off the interface 0/0 without trunking 0/1 to 0/0?  I would like to leave the voice network alone and just work with the data lans and create 2 vlans for the data network.  For instance:

vlan 1: 10.10.10.1 -> Default Data network -> Interface 0/0

vlan 3: 10.10.12.1-> Data network -> Interface 0/0

10.10.11.1-> Voice network -> Interface 0/1

Thoughts?  I would need all these networks to see one another as well.

Yes you can. You can leave fa0/1 alone and trunk fa0/0 for all your data VLAN's. All subnets will be able to talk to each other as long as your clients point to the router for the default gateway (which it sounds like they will).

Collin, thanks for the help.  I think my next question is above and beyong this forum but maybe you can help or direct me where to get the info. 

What is the config t commands for this? 

How will I "delete" what is currently setup for that interface?  Or will the new commands overwrite what is current?

If you were going to do this, how much time would it take you?

Reza Sharifi
Hall of Fame
Hall of Fame

Hi,

Referencing your post, these are not vlans.  Theses are physical interface on the router with IP address. If you are creating additional vlan on your switch, and want to use the existing interfaces (fa0/0 and 0/1) then you need to create a trunk on the switch and change the physical interface on the router to sub-interface, so you can add a 3rd subnet to the router without the need for an additional physical interface. 

HTH

Hello
As per Reza suggestion

Router
interface FastEthernet0/0
no ip addreess

interface FastEthernet0/0.1
Encapsulation dot1.q native
description Data Network vlan 1
ip address 192.168.xx.1 255.255.255.0

interface FastEthernet0/0.3
Encapsulation dot1.q native
description Data Network vlan 3
ip address 192.168.xx.1 255.255.255.0

On the switch (connecting to this fa0/0 interface)
int x/x
no ip address
switchport
switchport trunk encap dot1q
swutchport mode trunk
no shut

int vlan 1
ip address 192.168.x.x 255.255.255.0 * (in same ip range of vlan 1)

vlan 3
description Data Network vlan 3
exit


no ip routing
ip default-gateway 192.168.x.x ( ip address of routers vlan 1 interface)



access ports vlan 1
int xx
switchport host
no shut

access ports vlan 3
int xx
switchport host
no shut
switchport access vlan 3


May I ask what why you have a candidate default route set, are you running any routing protocol?
ip default-network x.x.x.x


res
Paul


Please don't forget to rate any posts that have been helpful.

Thanks.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

pdriver - Thanks that is good info.  I do have multiple switches so I assume this command needs to be run on all of them? I also do not run Cisco switches besides those on the backbone.  All switches are HP ProCurve's so I will need to find out the command for those.

Hello,

It would be best to review your topology before making any further decisions

can you post this and possibly a running config of a backbone switch

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

pdriver -

The backbone switch is a 2960.  Here is a cut down version of the running config.

macro global description cisco-switch

no aaa new-model

system mtu routing 1500

udld aggressive

mls qos map cos-dscp 0 8 16 26 32 46 46 56

errdisable recovery cause link-flap

errdisable recovery interval 60

port-channel load-balance src-dst-mac

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree extend system-id      

vlan internal allocation policy ascending

interface Vlan1

ip address 192.168.xx.xxx 255.255.255.0

no ip route-cache

ip default-gateway 192.168.xxx.xxx

ip http server

ip http secure-server

ip access-list standard private

ip sla enable reaction-alerts

Most ports are configured as:

interface Port-channel4

switchport mode access

where some are:

interface GigabitEthernet0/1

switchport mode access

channel-group 4 mode active

Or:

interface GigabitEthernet0/23

switchport mode access

switchport port-security

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

macro description cisco-desktop

spanning-tree portfast

spanning-tree bpduguard enable

Nothing major going on besides some LACP's. 

The HP Procurve's are very basic config:

hostname "HP ProCurve1"

time timezone 5

ip default-gateway 192.168.xxx.xxx

timesync sntp

vlan 1

   name "Data"

   untagged 1-28

   ip address 192.168.xxx.xxx 255.255.255.0

   exit

vlan 2

   name "Voice"

   tagged 1-28

   exit

no stack

spanning-tree

password manager

Thoughts?


First you'll want to erase the config for the fa0/0 interface

From config mode: default interface fa0/0

pdriver has listed all the commands you need to configure trunking.

You only need to configure the trunk on the interface (on the switch) that connects to the router. You'll want to add the new vlan(s) to the trunks from your 2960 to your HP's. If they are not trunking you'll have to configure those ports for trunking so the HP switches can have switchports in the new vlans. Can you post the results of a show interface trunk

Review Cisco Networking for a $25 gift card