cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
2784
Views
0
Helpful
6
Replies
Harsha A.
Beginner

Airplay/ChromeCast/Miracast between multiple VLANs

Hello Everyone,

 

I am sure most of you might have already guessed the topic after looking at the title :)

 

Well I currently have a task on my plate, where I need to make sure that the Airplay traffic flows between 2 different VLANs, to be exact I have an Airplay Receiver on let's say VLAN 40 and I have a Wireless user on say VLAN 50. 

 

I know that if you have a WLC present in your network, then there are ways to support this scenario.

However, in my case I do not have a WLC in the network and my AP is just a basic Linksys one (this is a Lab environment).

 

Please find my setup below:

Nexus 3548 (acting as Core Switch) ---> Port Channel 10 ---> Cisco 2960X 

Access Point is connected to Cisco 2960X and I only have 1 SSID (VLAN 50) on this AP.

L3 Interfaces for VLAN 40 and 50 are defined on the Nexus 3548.

I have IGMP snoooping, IGMP Querier configured and also have pim sparse mode enabled on both VLAN 40 and VLAN 50 to route the multicast traffic.

 

For my test, I have the receiver connected to VLAN 40 and my iPad is connected to the wireless on VLAN 50. I cannot even see the Airplay Receiver from VLAN 50.

 

I do know that I am missing something or there is a limitation with my setup but please do let me know your thoughts on this setup and how to make the airplay traffic flow between multiple VLANs without the WLC present in the network.

 

Thanks,

Harsha

 

 

6 REPLIES 6
Flavio Miranda
Advisor

Hello @Harsha A.

 On your Linksys, on the Firewall tab, do you have "Filter Multicast" checked ?

 

 

 

 

-If I helped you somehow, please, rate it as useful.-

Hello Flavio,

 

On the Linksys, I do not see any firewall option.

 

Linksys is currently working in Bridged mode and providing wireless access to VLAN 50.

 

-Harsha

Which version do you have. You should have a Security Tab somewhere and there you can allow/permit multicast.

 

 

 

 

-If I helped you somehow, please, rate it as useful.-

It's Linksys Smart Wifi (Linksys05714).

Under router Settings, you have security. Then in Firewall you have "Filter Multicast" make sure it is not checked.

 

 

-If I helped you somehow, please, rate it as useful.-

Hello Flavio,

 

AP is operating under Bridge mode.

 

This setting isn't present under Bridge mode.