cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
285
Views
0
Helpful
2
Replies

ASA 5505 and 1900 router Upgradation

srikanth ath
Enthusiast
Enthusiast

Hello Experts,

 

I was looking to upgrade the firewall(5505) and 1900(router) in my network. where both of them have been announced with the EOL by cisco.

Can you please provide what is the latest version of IOS versions i can use and these devices support to be upgraded too...As an engineer im week in these aspects so thought to get your reviews.

please find the existing IOS version on these devices.

5505#

 sh version

Cisco Adaptive Security Appliance Software Version 7.2(2)
Device Manager Version 5.2(2)

Compiled on Wed 22-Nov-06 14:16 by builders
System image file is "disk0:/asa722-k8.bin"
Config file at boot was "startup-config"

5505 up 1 year 200 days

Hardware:   ASA5505, 256 MB RAM, CPU Geode 500 MHz

 

1900#sh version
Cisco IOS Software, C1900 Software (C1900-UNIVERSALK9-M), Version 15.1(4)M3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2011 by Cisco Systems, Inc.
Compiled Tue 06-Dec-11 16:02 by prod_rel_team

 

Below are the Critical patches that the security team suggested to remediate their findings

1900#

CVE-2011-0935
CVE-2011-3271
CVE-2011-4012

 

ASA 5505

CVE-2007-2462
CVE-2012-0358
CVE-2010-4675
CVE-2010-4680

 

Thank you,

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Carlos Amador
Cisco Employee
Cisco Employee

On the ASA side, if you don't want to go through all the painful migration of NAT's passing 8.3, then you can stick with 8.2.5.57 which is the latest before going to 8.3. The 5505 supports up to 9.2 but if you are not looking for an specific feature on that code, then stay on 8.2; still very stable and should take care of the CVE's you attached

Regards,

View solution in original post

2 REPLIES 2

Carlos Amador
Cisco Employee
Cisco Employee

On the ASA side, if you don't want to go through all the painful migration of NAT's passing 8.3, then you can stick with 8.2.5.57 which is the latest before going to 8.3. The 5505 supports up to 9.2 but if you are not looking for an specific feature on that code, then stay on 8.2; still very stable and should take care of the CVE's you attached

Regards,

Oh, well thank you.. for the response i really appreciate....

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: