cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
995
Views
0
Helpful
4
Replies

ASR 1002-F Port-Channel to 3750X

ewells1492
Level 1
Level 1

Hello. I'm trying to setup a Port-Channel (or EtherChannel) between my ASR 1002-f Router and 3570X Switch.
I need to pass VLANs 10,20,30 & 40 over the Port-Channel (This is why I set the Switch ports as Trunks)

Need to confirm if this is the correct approach as the documentation can sometimes be a bit unclear.
Would you be so kind as to take a look below and advise if this is the correct approach and/or if i'm all wrong.
And provide direction/advice in order to achieve my goal.

Much appreciated :)


On ASR 1000 Router:

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end

Router# configure terminal
Router(config)# interface gigabitethernet0/0
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end

Router# configure terminal
Router(config)# interface gigabitethernet0/1
Router(config-if)# channel-group 1 mode active
Router(config-if)# exit
Router(config)#end

Router# write mem

The above should create a Port-Channel, assign an IP address of 192.168.1.1 and MASK of 255.255.255.0
to the Port-Channel itself. Then add Ports GigabitEthernet0/0 & GigabitEthernet0/1 to the Port-Channel as members.
Correct ??

On the 3750X Switch:

Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# end
Switch#

Switch# configure terminal
Switch(config)# interface range gigabitethernet1/0/49 - 50
Switch(config-if-range)# switchport mode trunk
Switch(config-if-range)# switchport trunk encapsulation dot1Q
Switch(config-if-range)# switchport trunk native vlan 10
Switch(config-if-range)# switchport trunk allowed vlan 10,20.30.40
Switch(config-if-range)# channel-group 1 mode on
Switch(config-if-range)# exit
Switch(config)#end

Switch# write mem

The above should create a Port-Channel, Then add Ports GigabitEthernet1/0/49 & GigabitEthernet1/0/50 to the Port-Channel as members.
Then allow vlans 10,20,30 & 40 over the Port-Channel correct ??

1 Accepted Solution

Accepted Solutions

you need sub interface at ASR Side, i believe the code should work.

 

example : ( apart from basic port-channel config both the side)

 

ASR 
=====
interface Port-channel1.10
 encapsulation dot1Q 10
 ip address 192.168.1.1 255.255.255.0


Switch side
=============
interface vlan 10
ip address 192.168.1.10 255.255.255.0

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

4 Replies 4

balaji.bandi
Hall of Fame
Hall of Fame

you want pass the VLAN to ISR you need to have L2 trunk and sub interface configure with do1q tag.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks for your reply.

 

Do you mean sub-interfaces created on the Interfaces on the Switch (3750). Or the ASR Router. (ASR 1002-F) ?

Also just to clarify, I only have an ASR 1002-F Router. Don't have an ISR (If you are referring to an Integrated Service Router. such as a 2951)

 

Would the same commands to accomplish my goal work with my ASR 1002-F Router ???

 

Thanks

 

 

you need sub interface at ASR Side, i believe the code should work.

 

example : ( apart from basic port-channel config both the side)

 

ASR 
=====
interface Port-channel1.10
 encapsulation dot1Q 10
 ip address 192.168.1.1 255.255.255.0


Switch side
=============
interface vlan 10
ip address 192.168.1.10 255.255.255.0

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thanks so much
I will give this a try today and let you know the outcome

Thanks again
Cheers
Review Cisco Networking for a $25 gift card