05-11-2016 03:35 PM - edited 03-08-2019 05:43 AM
Community,
I am trying to create a port channel between an ASR 1002 and a pair of 4500x Switches. However, I am having trouble understanding the VLAN based approach the ASR requires. I want to create a 2 port etherchannel using vlan 254 with IP address 10.252.254.2 255.255.255.0 on the router. The vlan 254 interface on the 4500x is 10.252.254.1/24.
Ive placed the following configs so far but am confused as to why I need 2 IP addresses, typically when creating subinterfaces under an interface on a router, only the sub interfaces need an IP and the main interface does not.. One IP address goes on the Po4 interface but then another IP address goes on the Po4.254 subinterface? Why the 2 addresses? and where do I put the 10.252.254.2 address? I want the 4500x and the ASR to be OSPF neighbors and only need vlan 254 to traverse the links. Any help you can provide would be great. thanks.
port-channel load-balancing vlan-manual
interface Port-channel4
ip address 10.252.254.2 255.255.255.0
no negotiation auto
!
interface Port-channel4.254
encapsulation dot1Q 254 primary GigabitEthernet0/0/1 secondary GigabitEthernet0/0/2
(Need IP address here)
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
channel-group 4
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
channel-group 4
05-11-2016 06:13 PM
Hi -
It should be as simple as assigning the IP to the sub-interface instead of the parent (which would be untagged traffic).
interface Port-channel4
no ip address
no negotiation auto
!
interface Port-channel4.254
encapsulation dot1Q 254
ip address 10.252.254.2 255.255.255.0
PSC
05-12-2016 04:56 PM
Paul,
Thanks for the reply. ill give that a whirl.
05-12-2016 06:03 PM
Paul,
Another question. To bring up OSPF, would I use the Port-channel4.254 subinterface as the non passive interface for the OSPF neighborship?
05-12-2016 06:05 PM
Yes.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide