01-28-2010 09:31 AM - edited 03-06-2019 09:29 AM
Hi,
I have a fairly simple CUCM install that I want to implement auto qos on (see above). What we have is as follows:
I have two 3825 ISRs with T1 PRIs located on opposite ends of our campus. One 3825 at location A is directly connected to a 4510 core switch in our data center. The other 3825 at location B is directly connected to a 3750 stack which is then trunked back to the core 4510 at location A. At each location we also have a CUCM server. Routers are connected to CUCM via H.323. At location A we also have a Presence server and a Unity server. At location A we have 8 VG224 analog gateways, 4 VG224s at location B, and 12 VG224s at another location. All VG224s use SCCP to CUCM. We then have all 3560 switches on our access layer and all of them are connected via fiber to the 4500 and the 3750 stack. We are using 7942 and 7962 handsets with a few 7941G-GE and 7961G-GEs sprinkled in. Almost all phones are using the switch port on the back of the phone to connect to PCs.
So what I'm wondering is how is the best method to implement auto qos on our network? Do we simply do the following:
1) Enable ip cef everywhere.
2) Enable auto qos voip cisco-phone on all access ports connecting to phones.
3) Enable auto qos voip trust on both sides of all switch trunk interconnects, both sides of VG224 switch links, and switch side of 3825 switch links.
4) Enable auto qos voip trust on switch links to CUCM, Presence, and Unity.
Am I missing anything? Is there a better or different way to do this? Is there anything else that needs to be done?
And lastly, is it not possible to enable Auto QoS on the 3825 GigE link side?
Thanks for all the help!!
Solved! Go to Solution.
01-28-2010 11:11 AM
AAhhh yes, the Cat 4500 with Sup6-E is different. Here is what I did to trust DSCP
class-map match-all AutoQos-VoIP-Bearer-Dscp
match dscp ef
class-map match-all AutoQos-VoIP-Control-Dscp26
match dscp af31
class-map match-all AutoQos-VoIP-Control-Dscp24
match dscp cs3
policy-map AutoQos-VoIP-Input-Dscp-Policy
class AutoQos-VoIP-Bearer-Dscp
set qos-group 46
class AutoQos-VoIP-Control-Dscp26
set qos-group 26
class AutoQos-VoIP-Control-Dscp24
set qos-group 24
class class-default
interface GigabitEthernet6/24
description CALLMANAGER-1
switchport access vlan 101
spanning-tree portfast
service-policy input AutoQos-VoIP-Input-Dscp-Policy
Message:
01-28-2010 09:35 AM
You are correct. One suggestion. After you have issued "auto qos voip trust" on uplink and server ports, enter "mls qos trust dscp". Voice servers and Gateways don't set L2 COS values, but they do set L3 DSCP values.
01-28-2010 09:53 AM
Hi William,
"mls qos trust dscp" doesn't seem to be available on my 4510R-E with Sup 6-Es? It does seem to be available on the 3750 though...
Does this make sense? We are running WS-X4648-RJ45V-E cards on the 4510 that the CUCM, Unity, and Presense servers plug into and WS-X4548-GB-RJ45V that the phones/PCs plug into. Neither seems to have this command available...
01-28-2010 11:11 AM
AAhhh yes, the Cat 4500 with Sup6-E is different. Here is what I did to trust DSCP
class-map match-all AutoQos-VoIP-Bearer-Dscp
match dscp ef
class-map match-all AutoQos-VoIP-Control-Dscp26
match dscp af31
class-map match-all AutoQos-VoIP-Control-Dscp24
match dscp cs3
policy-map AutoQos-VoIP-Input-Dscp-Policy
class AutoQos-VoIP-Bearer-Dscp
set qos-group 46
class AutoQos-VoIP-Control-Dscp26
set qos-group 26
class AutoQos-VoIP-Control-Dscp24
set qos-group 24
class class-default
interface GigabitEthernet6/24
description CALLMANAGER-1
switchport access vlan 101
spanning-tree portfast
service-policy input AutoQos-VoIP-Input-Dscp-Policy
Message:
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide