02-22-2019 11:19 PM
Dear All,
I am working on a scenario to limit the switch port on Cisco 3750 to have bandwidth of 8 mb/s up and down, currently this port is configured as trunk and i want to restrict vlan 10 (IP - 192.168.10.0/24) for 8 mb/s up and down. Need help in this regard.
Regards,
Talha
02-23-2019 12:25 AM
Hello,
below is an example. You need to configure 'mls qos vlan-based' on all physical access and trunk ports which are allowing VLAN 10 traffic, in addition to applying the service policy to the VLAN interface (SVI).
mls qos
!
policy-map VLAN10_8MB
class class-default
police 8000000 8000 exceed-action drop
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos vlan-based
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
mls qos vlan-based
!
interface Vlan10
service-policy input VLAN10_8MB
02-23-2019 12:41 AM
Hi,
You can archive your goal using the VLAN based configuration as below:
!
mls qos
!
policy-map V10_8MB
class class-default
police 8000000 8000 exceed-action drop
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos vlan-based
!
interface FastEthernet0/12
switchport mode trunk
switchport trunk allowed VLAN 10,11,12
mls qos vlan-based
!
interface Vlan10
service-policy input V10_8MB
And here is the link for better understating the configuration on this switch:
Regards,
Deepak Kumar
02-26-2019 12:26 AM
Dear Georg Pauwen,
I am getting this message when applying this to vlan interface. What should i do now ?
Switch(config)#int vlan 10
Switch(config-if)#service-policy input VLAN10_8MB
%QoS: policy-map with police action at parent level not supported on Vlan10 interface.
02-23-2019 01:38 PM
02-26-2019 12:46 AM
Dear Joseph,
I have configured an ISP vlan (layer 2) on my Cisco 3750-1 and trunked to other Cisco 3750-2 where i have Layer 4 Firewall which does all the NAT stuff and it is working like charm. now i have trunked this ISP vlan to another Cisco 3750-3 switch which resides in another business unit nearby. I want only this business unit not to exceed the speed of 8 mbps download and upload. Hope this clears up of what i exactly want to achieve.
02-26-2019 05:24 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide