cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
753
Views
0
Helpful
6
Replies

BGP establishment

corey.burden
Level 1
Level 1

Hello all,

I have two ASR routers that I use for my edge router.  Each router has one connection each to the same ISP on different routers from the ISP.  Each router is set up as a router on a stick with seven sub interfaces.  Each interface is a different customer.  I use VRF's to separate traffic and no RD's are configured.  Routing is currently done with static routing.  There are static routes in the global table that point to the subinterface then that same static route is also created in that vrf.  I point a static default route  to the ISP and a floating static route between the two ASR's for failover in the global routing table.  Each vrf also has a default and floating static route that are exported to the global table by adding the "global" option at the end of the static route command.    Then The ISP uses static routes to get back to individual subnets.  I have a requirement to switch to BGP.  When I switch to BGP is there anything special that I need to do with the VRF's that already configured to make sure that routing continues? I'm planning to advertise routes into BGP with redistribute static.    Here is what I have for a config so far:

router bgp xxx 39
no synchronization
bgp log-neighbor-changes
neighbor x.x.x.126 remote-as 39
neighbor x.x.x.126 description IBGP R1
neighbor x.x.x.126 update-source loopback 7
neighbor x.x.x.126 next-hop-self
neighbor x.x.x.126 soft-reconfiguration inbound
neighbor x.x.x.225 remote-as 64
neighbor x.x.x.225 description EBGP to ISP
neighbor x.x.x.225 route-map Filter_Routes in
neighbor x.x.x.225 route-map Filter_Routes out
neighbor x.x.x.225 soft-reconfiguration inbound
bgp default local-preference 200
redistribute static
neighbor x.x.x.225 password
!
ip as-path access-list 200 permit ^64$
ip as-path access-list 250 permit ^$
ip prefix-list accept_default_route seq 5 permit 0.0.0.0/0 le 32
!
ip bgp-community new-format
!
route-map Filter_Routes permit 10
match as-path 200
match ip address prefix-list accept-default-route
exit
route-map Filter_Routes permit 20
Match as-path 250
router bgp 39
no synchronization
bgp log-neighbor-changes
neighbor x.x.x.125 remote-as 39
neighbor x.x.x.125 description IBGP to R2
neighbor x.x.x.125 update-source loopback 7
neighbor x.x.x.125 next-hop-self
neighbor x.x.x.125 soft-reconfiguration inbound
neighbor x.x.x.225 remote-as 64
neighbor x.x.x.225 description EBGP to ISP
neighbor x.x.x.225 ebgp multi-hop 5
neighbor x.x.x.225 route-map Filter_Routes in
neighbor x.x.x.225 route-map Filter_Routes out
neighbor x.x.x.225 route-map Prepend_AS39
neighbor x.x.x.225 soft-reconfiguration inbound
bgp default local-preference 50
redistribute static
neighbor x.x.x.225 password
!
ip as-path access-list 200 permit ^64$
ip as-path access-list 250 permit ^$
ip prefix-list accept_default_route seq 5 permit 0.0.0.0/0 le 32
!
ip bgp-communtiy new-format
!
route-map Prepend_AS39
set as-path prepend 39 39 39
route-map Filter_Routes permit 10
match as-path 200
match ip address prefix-list accept-default-route
exit
route-map Filter_Routes permit 20
Match as-path 250

An example of a current static route to Customer A with a global and vrf static route:

ip route x.x.45.0 255.255.254.0 TenGigabitEthernet0/0/0.3 x.x.x.129

ip route vrf custA-vrf x.x.45.0 255.255.254.0 x.x.x.129

6 Replies 6

Hi

If you are going to advertise the customer subnets through BGP and using VRFs, you need to create individual address families for each VRF and into each one configure the peerings and other arguments

basic example:

router bgp 100
no sync
no auto
no bgp default ipv4-unicast

address-family ipv4 vrf A
neighbor 1.1.1.1 remote 101
neighbor 1.1.1.1 activate
<other arguments>

address-family ipv4 vrf B
neighbor 1.1.1.1 remote 101
neighbor 1.1.1.1 activate
<other arguments>

address-family ipv4 vrf C
neighbor 1.1.1.1 remote 101
neighbor 1.1.1.1 activate
<other arguments>

It is just and example you should adjust it to your requirements. 

Hope it is useful

:-)




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Thanks Julio.  Would this be the case even if the subnets are in the global table with the static routes?

Corey

Hi

You are welcome, no if the subnets are in the global routing it should be included on the normal IPv4 family address. 




>> Marcar como útil o contestado, si la respuesta resolvió la duda, esto ayuda a futuras consultas de otros miembros de la comunidad. <<

Hi corey.burden,

If you want to get rid off static routing completely then you can configure Intervrf routing or vrf to default or vice versa by using BGP. This will give you more granular control over routing.

There is not a requirement to remove static routing at this point and Intrevrf routing would violate our security requirement so that wouldn't work anyway.  But thanks for that information. 

Ok great.  Thanks Julio

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card