Showing results for 
Search instead for 
Did you mean: 

Booting a CAT6509 from a Sup720 Disk0: with IOS



I have a Cat6509 that I am building. It has a Sup720 (WS-SUP720-3BXL) in slot 6 that I want to boot from (with IOS 12.2)

Apparently the bootflash has CatOS on it. Please see Show Ver below. The PCMCIA card I want to boot from has IOS on it (s72033-adventerprisek9_wan-vm ver 12.2).

When I enter the command to set the boot device to pcmcia slot0, I get an error stating 'Feature not supported on Module 6'. See below.

Can someone tell me what I am missing here? Do I need to upgrade the Sup720 bootflash to IOS before this will work?

I am not very familiar with 6509's. I have worked much more with GSR's and other platforms, but very little with 6500's. Any help would be most appreciated.



Console> (enable) set boot device pcmcia:slot0 6

Feature not supported on Module 6.

Console> (enable) sh ver

WS-C6509 Software, Version NmpSW: 8.4(5)

Copyright (c) 1995-2005 by Cisco Systems

NMP S/W compiled on Aug 3 2005, 11:40:47

System Bootstrap Version: 8.4(2)

System Boot Image File is 'bootflash:cat6000-sup720k8.8-4-5.bin'

1 Accepted Solution

Accepted Solutions

It means you are running Software Modularity in binary mode. No need to worry about that message. It's just a warning.

Please read more at this link:


View solution in original post

8 Replies 8

Edison Ortiz
Hall of Fame Mentor Hall of Fame Mentor
Hall of Fame Mentor

Thank you. I will have a look.

This doc worked well, thanks.

There is just one remaining issue I am having. The switch is now booting from disk0 (IOS) with no problem however, in the show ver I get the error shown at the bottom.

I am assuming this is because the bootflash still has an old image?? However, during this process I tried to copy the IOS into bootflash but it was too big.

I have looked up this command but I can not find any info on it in the 'Command Lookup Tool' Even the command 'Install' does not show up there.

Of course I could try a few things but I don't want to break anything either. Can anyone recommend how I should proceed with this error?



"Patching is not available since the system is not running from an installed image. To install please use the "install file" command"

It means you are running Software Modularity in binary mode. No need to worry about that message. It's just a warning.

Please read more at this link:


One last question here and I will stop bugging you :-), I promise.

On the same disk0, I also have this image: s72033-adventerprisek9_wan-vm

If I'm not mistaken, this one is does not use SW Modularity.

So, If I use:

boot system disk0:s72033-adventerprisek9_wan-vm

Then this message should go away?

Thanks for all your help.


Ok, I now have this working the way I wanted it.

Here's how I did it.

I had a blank PCMCIA card that I inserted into another 6509 running the version of IOS I wanted. I formated the disk and copied over this file from disk0: to disk1:


I then inserted this new PCMCIA card into the new 6509 and used the procedure listed here to convert from Cat OS to IOS.

That worked except for the one issue listed above. I went ahead and installed the image to get rid of the message in the show ver. Now the switch is booting from the same IOS as the other switch.

Here are the 2 commands needed to do this. The first command is done from enable mode, the 2nd is done from conf term.

install file disk0:s72033-adventerprisek9_wan-vz.122-18.SXF6.bin disk0:s72033-adventerprisek9_wan-vz.122-18.SXF6.bin disk0:/sys/s72033/base/

install bind disk0:/sys/s72033/base

One thing I learned about this is that when you install this :


The install creates, and then boots from this:


All is well now.

Thanks again,


Excellent write-up Steve !

Yes, with software modularity the process is now done by using the install file routine.

Good job.

Thanks. I wanted to document what I did since I was not able to find info on the 'install file' command.

Thanks also for your help. I appreciate you taking the time to answer my dumb questions :-).


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers