Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Bootstrap from DHCP with Cisco 2960-X, 3560-C/CX

Hi guys,

I've got Prime Infrastructure 3.0.2 installed and I'm trying to get Plug and Play (PnP) working with CNS on PI.

- The switches we tend to deploy are 2960X, 3560-C/CX and I have got our Windows DHCP server configured with Option 150 to point to PI.

However when plugging these 'out of the box' switches into our network, the switches don't get an IP via DHCP...

- I don't think they are shipped with IP address DHCP on the Vlan 1 interface.

How can I get this working without having to console into each switch??

I have tried bootstrapping from a USB drive but with no success because the switch still doesn't have an IP address on any SVI or interface.

Any help would be greatly appreciated.



Pedro Silva

I am having the same issue. Were you able to find an answer?

I can't work out how to make the switch look for a DHCP address and can't find any documentation for this feature.

Hi Pedro,

Sorry I'm still having the same issue. I can't work out how to get it to work.

I've logged a TAC case.

I can't see any documentation explaining under what conditions the C2960X will try to find a DHCP server.

Pedro Silva

TAC came back and suggested doing a "write erase" and a reload.

I did this and connected int gi1/0/1 to a normal access port on one of our switches.

After the switch loaded it found the DHCP server and loaded the bootstrap config.

Cisco IOS Software, C2960X Software (C2960X-UNIVERSALK9-M), Version 15.0(2a)EX5, RELEASE SOFTWARE (fc3)

Technical Support:

Copyright (c) 1986-2015 by Cisco Systems, Inc.

Compiled Mon 16-Feb-15 08:16 by prod_rel_team

Jun  3 01:07:25.995: %USB_CONSOLE-6-MEDIA_RJ45: Console media-type is RJ45.

Jun  3 01:07:26.732: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to down

Jun  3 01:07:27.637: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/1, changed state to up

Jun  3 01:07:29.591: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/1, changed state to up

Jun  3 01:07:57.606: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up got vend id vend spec. info ret: succeed

Jun  3 01:08:18.315: AUTOINSTALL: Obtain tftp server address (opt 150)

%Error opening tftp:// (No such file or directory)

Loading cisconet.cfg from (via Vlan1): !

[OK - 4300 bytes]

 I am now trying to get it to pick up the ride credentials profile.

Hi Pedro,

Thanks for the update! I managed to get my switch to actually boot to the AUTOINSTALL command too... but my switch actually trys to use OPTION 66 (BootServerHostName) instead... :(

I need option 66 in my DHCP scope for use with our Microsoft SCCM infrastructure but it appears as though the AUTOINSTALL uses Option 66 before it looks at Option 150!

I may need to start a TAC case for my scenario...