cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
254
Views
5
Helpful
2
Replies
Highlighted
Beginner
Beginner

Buffer Allocation problem on 10Gig int on 3850

Hello!

Please, can someone explain me why I have a 1Gig buffer allocation conf on a 10Gig int? What can we tune?

 

Initially, I found errors on interfaces on a 3850 (ver 03.07.03E)

Port        Align-Err     FCS-Err    Xmit-Err     Rcv-Err  UnderSize  OutDiscards
Te1/0/1             0           0           0           0          0            0
Te1/0/2             0           0    40349970           0          0     40349970
Te1/0/3             0           0           0           0          0            0
Te1/0/4             0           0           0           0          0            0
Te1/0/5             0           0           0           0          0            0
Te1/0/6             0           0      144190           0          0       144190
Te1/0/7             0           0     3479472           0          0      3479472

I found this document from Cisco : Catalyst 3850: Troubleshooting Output drops

So I checked my conf

Switch#show platform qos queue config Te 1/0/7
DATA Port:6 GPN:7 AFD:Disabled QoSMap:0 HW Queues: 48 - 55
  DrainFast:Disabled PortSoftStart:1 - 1080
----------------------------------------------------------
  DTS Hardmax   Softmax  PortSMin GlblSMin  PortStEnd
  --- --------  -------- -------- --------- ---------
 0   1  5   120  6   480  6   320   0     0   3  1440
 1   1  4     0  7   720  3   480   2   180   3  1440
 2   1  4     0  5     0  5     0   0     0   3  1440
 3   1  4     0  5     0  5     0   0     0   3  1440
 4   1  4     0  5     0  5     0   0     0   3  1440
 5   1  4     0  5     0  5     0   0     0   3  1440
 6   1  4     0  5     0  5     0   0     0   3  1440
 7   1  4     0  5     0  5     0   0     0   3  1440
 Priority   Shaped/shared   weight  shaping_step
 --------   ------------   ------  ------------
 0      0     Shared            50           0
 1      0     Shared            75           0
 2      0     Shared         10000          26
 3      0     Shared         10000           0
 4      0     Shared         10000         120
 5      0     Shared         10000           0
 6      0     Shared         10000          48
 7      0     Shared         10000           0

   Weight0 Max_Th0 Min_Th0 Weigth1 Max_Th1 Min_Th1 Weight2 Max_Th2 Min_Th2
   ------- -------  ------  ------  ------  ------  ------  ------ ------
 0      0     478       0       0     534       0       0     600       0
 1      0     573       0       0     641       0       0     720       0
 2      0       0       0       0       0       0       0       0       0
 3      0       0       0       0       0       0       0       0       0
 4      0       0       0       0       0       0       0       0       0
 5      0       0       0       0       0       0       0       0       0
 6      0       0       0       0       0       0       0       0       0
 7      0       0       0       0       0       0       0       0       0

We do not have policy applied

Switch#show policy-map int TenGigabitEthernet 1/0/7
Switch#

Default conf for a 10Gig Interface from the Cisco doc

3850#show platform qos queue config tenGigabitEthernet 1/0/37
DATA Port:1 GPN:37 AFD:Disabled QoSMap:0 HW Queues: 8 - 15
  DrainFast:Disabled PortSoftStart:2 - 6480
----------------------------------------------------------
  DTS Hardmax   Softmax  PortSMin GlblSMin  PortStEnd
  --- --------  -------- -------- --------- ---------
 0   1  6   720  8  2880  7  1280   0     0   4  8640
 1   1  4     0  9  4320  8  1920   3  1080   4  8640
 2   1  4     0  5     0  5     0   0     0   4  8640
 3   1  4     0  5     0  5     0   0     0   4  8640
 4   1  4     0  5     0  5     0   0     0   4  8640

 

2 REPLIES 2
Highlighted
Beginner

What version of software are you running? I believe in one of the 3.6.x releases (maybe 3.6.6 or 3.6.7?) this was fixed so that 10G interfaces no longer had that issue.
Throwing packets since 2012
Highlighted

sh ver
Cisco IOS Software, IOS-XE Software, Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 03.07.03E RELEASE SOFTWARE (fc3)

If we updated the switch after its installation and configuration, can it have kept this configuration from the bug?

 

Also there must be no impact but the boot loader version is 3.58.

Content for Community-Ad