ATTENTION: We are currently working an issue with posting. Thank you for your patience while we work on a resolution.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1946
Views
0
Helpful
14
Replies

Building a test network

jimtully03
Level 1
Level 1

Hey folks. I have been put in charge of getting a failover cluster up and runing for SQL AlwaysOn. My equipment is a Cisco SF300-24 and a Cisco 2024 smartswitch. Now I am really new at this since my CCNA class has not yet started but I am trying to get a headstart. What I need to do is split the network up into 2 vlans to represent my data center, and the network oporation center. Ports 1,2,and 3 will be my DC; 11 and 12 will be my NOC. I need to learn how to get those two vlans to communicate. trunk? how? I need the computers to communicate flawlessly.  I would rather use the Cisco CLI and not the GUI but if someone could please help me out, google is comming up with nothing descriptive. please help me!

Jim

14 Replies 14

TomF
Level 1
Level 1

Hi Jim,

I am not sure if I understand your question. However (and also I am new at this stuff) you need to create the 2 VLANs, assign the ports to the vlans and setup routing between the Vlans.

The vlans you create using the vlan command

The ports you assign via: switchport access vlan vlan-id

As far as I can see the sf300 can do routing between vlans. So take a look at the manual to get you going.

Goodluck

Tom

Sent from Cisco Technical Support iPad App

Thanks for the help Tom.  I got to the point where I need to get the two vlans to communicate. I believe this is done with LAG and trunking? but I'm not sure and dont know how.  I'm not sure if I need to take the same ethernet cable and plug one end into a vlan 1 port, and the other end into a vlan 2 port to make a trunk, then do something with LAG.

Jim

Hi,

If you would use a separate router then you could use a trunk and use a router on a stick. I guess you want to use the sf300 and route between the vlans, right?

Sent from Cisco Technical Support iPad App

correct. the sf300 is just the router. then the easiest way to explain it is the top row of the smartswitch is vlan 1, the bottom row is vlan 2.

Rick Morris
Level 6
Level 6

Based on your info I am thinking you need layer 3 capabilities since there will be hosts hanging off the switches and you want communication between the vlans.  I am not familiar with the series switch you are using.  If it does you will create vlan interfaces (SVI's) and apply an IP address to each.

What are you using for the routing?

You can create vlans on each switch and apply the vlans to the appropriate interfaces.

This is a good link for some configuration:

http://www.youtube.com/watch?v=9IaDFx0nDfA&feature=related

about 4:50 is where the config portion begins.

If you are going to attach another switch you can set this up by a trunk and then allow all vlans across the trunk or you can allow specific vlans only.

Here is a good link that will help with different switch configurations

http://www.cisco.com/en/US/docs/switches/lan/catalyst2950/software/release/12.1_6_ea2c/configuration/guide/swgports.html

Thank you for the info Rick. I will check out the links and go from there.  The SF300 is a layer 3 switch.

Ok, this is perfect.  Then you will create the SVI's on that switch and these will be the default gateways for the hosts plugged into the switch.

So the config will look like this:

interface vlan <#>

description

ip address

You will do this for each vlan you want

interface vlan 10

description Servers

ip address 10.0.1.1 255.255.255.0

!

interface vlan 20

description PC

ip address 10.0.2.1 255.255.255.0

!

interface vlan 30

description Wireless

ip address 10.0.3.1 255.255.255.0

!

The next thing you will need to do is place each interface in switchport mode and create an access or trunk.

For an end device, server or host it will be an access port

For attaching another switch you would want to create a trunk.

Sample trunk config:

interface GigabitEthernet 1/1 (or whatever the interface numbering is like could be 1/0/1)

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allow all (if you want to allow all, by default this is what is set up - or you could specify specific vlans to trunk, in that case it would look like  switchport trunk allow vlan 10,20 and if you did not want vlan 30 on the downstream switch you would simply leave it out of the allow vlan statement.)

The interface config for access looks like this:

interface GigabitEthernet 1/1 (or whatever the interface numbering is like could be 1/0/1)

switchport

switchport mode access

switchport access vlan

Thank you so much Rick!  That was perfect.  Now I set everything up and thought it was right, but i still cannot remote from one pc to the other.  Is there a way to diagnose communication within the switch?

Let's take a step back and verify a couple of things first.

When looking at the interfaces of the switch do you see them up/up?

What I am looking for here is to see if the end station is on and connected as well as the interface up and not admin down. 

On the work stations are you able to see if you get an IP address?  ipconfig /all to see if it is getting everything.

From each work station can you ping the default gateway?  What we are looking for here is basic network connectivity back to the routed interface.

If you can ping the default gateway can you then ping each host end to end?  It is possible the work stations have firewall on and blocking remote connections?  It could be possible that the communication between vlans, assuming each host is in a different vlan, is not working properly.

Actually, before we even try to troubleshoot.  Is my equipment good enough for this? SF300-24 and SLM2024.  Can this all be done just by using the SF300-24?  All the vlans and whatnot?  The SLM2024 is not a managed switch but has the GUI.

I must admit that I have not ever worked on either of these but what you are doing is no different than any other switch platform so I imagine that what you are wanting to do will work with what you have.  The big piece is the routing, or intervlan routing, and you said the one switch is a layer 3 switch so you should be fine there.

OK so the layer 3 (sf300) can only be the router correct?  or can it also act as my switch?

Yes, it is both so to speak.  It is a switch that can do layer 3 routing. 

OK great!   the problem now is it does not seem to know the encapsulation command or i am doing something wrong. Can we start from the top?  ports 1,2,3 in vlan 10. ports 10,11,12 in vlan 20  Below is how i started from the very beginning. I'm not going to type all the exit commands or config commands but here are my steps.

Version 1.1.2.0

#set system mode router

#y

#config

#vlan database

#vlan 10

#name NOC

#vlan 20

#name EDC

#show vlan

#config

#int fe1

#switchport mode access

#switchport access vlan 10

#int fe2

#switchport mode access

#switchport access vlan 10

#int fe3

#switchport mode access

#switchport access vlan 10

#int fe10

#switchport mode access

#switchport access vlan 20

#int fe11

#swithcport mode access

#switchport access vlan 20

#int fe12

#switchport mode access

#switchport access vlan 20

#show vlan

now what?

Review Cisco Networking for a $25 gift card