cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

5850
Views
10
Helpful
9
Replies
Highlighted
Beginner

c3550 xmodem issue

Hi,

I´m stuck with reanimation of a c3550-48 switch who died from a corrupted OS file. It seems to me that the xmodem operation is the source of trouble.

I followed the document "Recovering Catalyst Fixed Configuration Switches from a Corrupted or Missing Image" (http://www.cisco.com/en/US/customer/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml) which includes the exact model I´m working on and shows the procedure in detail. I also searched this forum, but nothing worked out.

Here is what happens:

Flash was formatted and fsck´ed, everything fine. (bytes total : 15.998.976, bytes available 15.996.928)

Now I try to copy:

switch: copy xmodem: flash:c3550-i9q312-mz.121-22.EA9.bin    (image file size 3.512.357)

and get the "Begin the Xmodem or Xmodem-1K transfer now..." message with some "CCC" in the next line. I point the terminal program to the said OS file, hit send and the program starts to transfer and continues that to 100%. However, according to the above documentation, the switch should show the progress as well by displaying lots of "....." (like "!!!!" when you do tftp) - but there is nothing of that. When the transfer is finished, two more "C"s are printed, then a few seconds delay, then the switch gives me "xmodem::  I/O error" and that´s it.

I tried:

- different OS file versions up to the current release

- different OS file types (.bin without GUI and .tar with GUI)

- different serial interfaces (one built in the mainboard, another via USB-to-serial-adapter with Prolific chipset)

- different terminal emulation programs (teraterm, hyperterminal)

- different speeds (115.200 and yes, I even spent the whole Sunday trying this at 9600 baud ^^)

All lead to the same result.

Any idea what else I could try ?

Everyone's tags (3)
9 REPLIES 9
Engager

c3550 xmodem issue

Please try another terminal emulator program.

You did not state what you are using but not all x-modem implementations are working correctly.

With a different version, you should see a result which is more in line with the documentation.

regards,

Leo

Beginner

c3550 xmodem issue

Tried TeraTerm (4.6.0) and HyperTerminal v5.1, do you have any recommendation ?

Engager

c3550 xmodem issue

It has been a long time since I had to do this but I guess TeraTerm is a good choice.

If that is what you are using, please check the flow control settings and change them to NONE or HARDWARE.

Do not use X-on X-off, that will not work with xmodem transfers.

Leo

Cisco Employee

c3550 xmodem issue

Hi

I guess u tried all the possible options, i suspect it could be a hardware issue as well.

Thanks

Somu

Beginner

c3550 xmodem issue

All,

thanks for your help and suggestions, I have now successfully transferred an OS file and the switch booted into IOS.

Here is what helped:

- Against what is written in the documentation linked above, I switched back to 57600 baud instead of 115200. I tried that since I recognized the error counter going up when transferring with HyperTerminal. TeraTerm does not have that feature and happily sends away without any feedback.

- I also tried different serial cables and ports, the working combination was a CAT5-cable instead of the blue one we´re all familiar with.

So the combination of better cable and lower speed may have helped the signal quality, in the end it paid off.

Since I was used to TFTP-transfers only, I expected Hyperterminal to produce some output as shown in the said documentation. BUT ! during the transfer, you only see the transfer window and counters, the console display is not updated. Only after the transfer is finished you see the "wall of dots" that is shown in said paper.

I guess it really was some sort of hardware issue, but no switch hardware in that case . Have seen a few dead green boxes, even brand new SUPs suddenly going *poof*, luckily this one coudl be saved (as it sits in my private lab that I just build for further self-education).

Cheers and thanks to all for your support !

Beginner

c3550 xmodem issue

Thanks.

I tried work with HyperTerminal, SecureCRT and TeraTerm on 9600 and 115200 speed rates.

But problem still occur.

And 57600 speed rate saved me

--

Sergey

Beginner

c3550 xmodem issue

I just wanted to add to this issue, because I was having the same problem.  I tried upload an image to my 3550.  I tried at speeds 9600,57xxx, 112xxx - all failed (i was using teraterm).

I download HyperTerminal on my Windows 7 machine using 57xxx speed, and the image loaded correctly.

Hope this helps someone. GL!

Beginner

Re: c3550 xmodem issue

thanks keller.oliver

This iissue realy troubled me, thanks to you i got it working.

Here is what is did

1.connect your console cable to the console port of the device and pc console port

2.use hyerterminal software and login to the switch

now issue the following at the switch:

switch: flash_init

switch: load_helper

switch: set BAUD 57600

3.Close the terminal software and restart it again

4.change the console connection settings speed to 57600 to sync with the switch

5.initiat the command copy xmodem: flash:"ios image name here"

6.Use the transfer at the tastbar of the hyperterminal software and click sendfile, now search for the location of the ios

and change the protocol to xmodem then click send...

Upload of the ios begins....

7.After ios upload, initiat the command at the switch:boot flash: "ios file name here"

eg. switch:boot flash:c3550-ipservices-mz.122-44.SE6.bin

remember to change the port speed back to 9600 when ios is functioning, switch:set baud 9600

Good luck, God is love.....

Beginner

Re: c3550 xmodem issue

I was having the same type of issue today while trying to resurrect a 3750V2 switch.  I started by using TeraTerm and eventually went to HyperTerminal.  Thanks to HyperTerminal, I was able to see a high percentage of retries.  Looking back at TeraTerm, I was having the same type of issue but there was no indication from TeraTerm what the problem was.  It would just stop part way through the file transfer.  Based on some of the info in this thread, I was able to trace the problem to a USB to DB-9 serial adapter that I was using with my console cable.  Switching to a RJ-45 to USB console cable eliminated all errors and the file is transferring as I type this.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards