cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10905
Views
0
Helpful
8
Replies
Highlighted
Beginner

C3750 interVLAN routing - no internet access for client switches

I'm having a stupid issue with my (intervlan) routing.

I have a test setup of a C3750 stack as a core and some 2960's as access switches.

http://users.fraeco.be/setup.png - The switches at the bottom is the new network (VLANNED). The switches on the left is the current production network (10.1.1.0/24)

From the C3750 to the router is a /30 network.

There will be 6 VLANs but at the moment I have one configured. VLAN50 - 10.5.1.0/24

From the C3750 I can ping my current production network, internet, other VLANs in the testsetup, ... Everything.

From the C2960 I can ping other VLAN's, reach the gateway, reach the router, reacht the currenct production network. But I can't reach internet. I've configured "ip default-gateway 10.5.1.254" on the C2960. C3750 relevant config is down below.

How is it that I can reach other networks connected to the router and not internet from the access switches? I'm just trying to ping 8.8.8.8.

!

ip routing

!

!

interface GigabitEthernet1/0/1

no switchport

ip address 172.16.1.2 255.255.255.252

!

!

interface Vlan50

ip address 10.5.1.254 255.255.255.0

!

!

ip route 0.0.0.0 0.0.0.0 172.16.1.1

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi Maxim,

I dont have idea about your configuration exactly but on the behalf of the information that u provided i can say...configure all respective hosts to its respective vlan ip as gateway.

There should be static route pointing towards the Router on MLS switch.

And also make sure there should be static ( or dynamic entries in case u r using IGP )of all subnets of vlans pointing towards the directly connected ip of MLS switch.

It will definitely work.

Thanks

Amit

Please rate if this post would be helpful.

View solution in original post

8 REPLIES 8
Highlighted
Beginner

Just did some more testing.

If I hook up client machines to the C3750 they aren't able to ping internet as well. Again, I can ping my entire corp network, but not able to ping to internet. If I ping directly from the switch, it's working.

Highlighted

HI I can not find your issue with this info but still , u can check this first :

see the example:If you are configuring on Router


Create sub-interfaces, set 802.1Q trunking protocol and ip address on each sub-interface

Router(config)#interface f0/0
Router(config-if)#no shutdown

(Note: The main interface f0/0 doesn’t need an IP address but it must be turned on)

Router(config)#interface f0/0.0
Router(config-subif)#encapsulation dot1q 15
Router(config-subif)#ip address 192.168.15.1 255.255.255.0
Router(config-subif)#interface f0/0.1
Router(config-subif)#encapsulation dot11 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

(Note: In the “encapsulation dot1q 15″ command, 15 is the VLAN ID this interface operates in)

Configure VLAN

Switch(config)#vlan 15
Switch(config-vlan)#name SALES
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name TECH

Set ports to access mode & assign ports to VLAN

Switch(config)#interface range fa0/1
Switch(config-if)#no shutdown
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 15
Switch(config-if)#interface range fa0/3
Switch(config-if)#no shutdown
Switch(config-if)#switchport mode access
Switch(config-if)# switchport access vlan 20

Example:If you are configuring on layer 3 switch:

ip routing
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 20
switchport mode access

interface Vlan15
ip address 192.168.15.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0

ip route 0.0.0.0 0.0.0.0 172.16.1.1

And  on hosts just assign IP addresses and default gateways (to the  corresponding interface VLANs) -> hosts in different VLANs can  communicate.

If all are ok ...and still not working then please past your config and complete topology.

Regards

Please rate if it helps.

Highlighted

Hi Maxim,

I dont have idea about your configuration exactly but on the behalf of the information that u provided i can say...configure all respective hosts to its respective vlan ip as gateway.

There should be static route pointing towards the Router on MLS switch.

And also make sure there should be static ( or dynamic entries in case u r using IGP )of all subnets of vlans pointing towards the directly connected ip of MLS switch.

It will definitely work.

Thanks

Amit

Please rate if this post would be helpful.

View solution in original post

Highlighted

The problem is solved. And it wasn't in my config. If you think about it, it couldn't be. I could ping all possible interfaces of my router EXCEPT the WAN interface.

After a check in the router's routing table I noticed it was only routing to the VLAN's when the package came from a LAN interface, and not WAN.

Thanks for the insights though!

Highlighted

Hi Maxim,

Thank you so much by considering my answer as helpful and kept it down as u got expected result..

Enjoy posting over here..hopw we can bring some more useful help to you...

Thanks once again

Amit

Highlighted

What exact configured did you put? Have same issue

Highlighted

So how did you get it to route to the WAN interface?

Highlighted

i had the same problem.

i went to internet router and add there static routes to my vlans.

such as:

192.168.4.0 255.255.255.0 192.168.1.1

192.168.2.0 255.255.255.0 192.168.1.1

 

 

Where 192.168.1.1 - c3750 svi ip.

(My router`s ip is 192.168.1.15)

After that internet appears in vlans, which i described on the router.

 

But i got another problem:). 

I have two gateways in my network, and computers, that have different gateways, didn`t ping each other. 

solution was the same:)). i just add same routes on second router.

such as:

192.168.4.0 255.255.255.0 192.168.0.5

(where 192.168.0.5 - is svi ip address of c3750, and this router have ip address 192.168.0.1)

After that i could ping everything from everywhere:).

P.S. Hate people, that didn`t write solution after question.:\

It could be very helpful for many beginners.

My routers are very simple - keenetic 4g ii and tp-link.

Keenetik have very pour web-interface, but excellent cisco-like cli ( official firmware, not ddwrt).

Tp-link didn`t have cli, but it allows to add routes in web-interface.

Content for Community-Ad