Showing results for 
Search instead for 
Did you mean: 

Can't access SG300-52P Using Console Port - Please help


Sorry for posting so many questions about issues with connecting to devices, and thank you in advance for all the help.


Okay, so I am trying to access a SG300-52P using the Console port (DB9 port on the back of the switch). I purchased a USB to RS232 Serial Cable (The cable I purchased) which has a Prolific PL-2303 RA chipset. The pinout for the adapter is:


  1. Carrier
  2. Tx
  3. Rx
  4. DSR
  5. Gnd
  6. DTR
  7. CTS
  8. RTS
  9. Ring

It showed up in my device manager as COM5.  So I first configured my PuTTY settings as:

Serial: COM5

Baud: 9600

Data Bits: 8

Stop Bits: 1

Parity: None

Flow Control: None

I plugged in the switch and no response in PuTTY at all. Just a blank console window with the curser blinking in the top left. I also attempted to connect with all the same settings, but changing the Baud to 115200 in PuTTY. Still nothing.


I then double clicked the USB to serial Comm port in device manager to open the properties and made sure the settings in the "port settings" tab match the settings I used in PuTTY (I tried this both for Baud = 9600 & Baud = 115200) and still no response or anything in the PuTTY console window.

I a hoping to avoid doing a factory reset on the device, and I don't know the password to SSH into the switch (the last Network admin left without leaving any information or passwords or configurations or anything)  I have also tried the above steps with This Cable again, with no luck.

Does anyone have any advice or see anything that I messed up on with configuring PuTTY or with the cables?  Any help or advice at all would be greatly appreciated. Thank you.


4 Replies 4

Reza Sharifi
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Try the other baud rates like 38400 and 57600


I tried several other baud rates with no luck. I checked the pinout of the SG300 console port and the cable and they match so it shouldn't be the cable, right?

Do you have a second com port you can test with?

Also, does the new cable comes with a driver? If not, you can probably download and installed it and see if that makes a difference.

I can change the COM port that my computer assigns, and I did download the latest driver. I am attaching the advanced settings for the COM in the device manager to make sure it's correct.

SG300 COM advanced settings.PNG


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers