Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!

Can't Login on my SG350 - With the Wifi Adapter ON

So.. I am on a OSX Mac.


If I wifi adapter airport on I cant login into the Switch.


Even ping does not work. As soon as I stay with only ethernet it works again.


Whats the deal?


Thank yoScreen Shot 2019-05-06 at 20.45.06.png


Accepted Solutions

Hi just to let you know.



After configuring the switch to accordingly these setting i got it working.




It works with no problem now .. so there was something from those options that enabled and now its full on.


thank you

View solution in original post

VIP Expert

Not sure how your SG350 configured, is this allowed any one from outside to login ?




*** Rate All Helpful Responses ***

I am a very beggining. I bought to learn and test.


So it was my first login, it is in default configuration. 


Straight from my ethernet out from computer, if I am not using my WAN internet access through wifi I can login and ping.




ether c8:bc:c8:a6:c0:6a

inet6 fe80::cabc:c8ff:fea6:c06a%en0 prefixlen 64 scopeid 0x4

inet netmask 0xffffff00 broadcast

nd6 options=1<PERFORMNUD>

media: autoselect (1000baseT <full-duplex>)

status: active


i perform ifconfig and it detects it. its highlighted in green, but can't reach it


Screen Shot 2019-05-06 at 20.59.02.png



That is broacast IP address not Gateway IP address.


Try from command level ifconfig or route and port


or ping or (one of them i expect to be your Gateway)


*** Rate All Helpful Responses ***

yes you are correct. i was pinging the wrongone anyway even with the correct is not working


Screen Shot 2019-05-06 at 21.13.29.png


so you see WIfi is off. I can login. as soon as I turn wifi on. I loose all access! even pinging or on my web browser

just make clear understand what we are doing here..


1. you have access to device when you connected to Ethernet all works - Good hear this point.

2. when you remove from Ethernet you lost all connection not able to ping - lets start from here.

    - when you remove ethernet cable. do you have auto connection throough ?

    - what is the IP address from Wifi range you getting

    - until you have setup to get same IP range, Wifi pool may be different, you have not clarified this.

   - if the wifi ip pool is different what IP pool is that ?

   - have you setup that wifi IP pool also can access device administartion, liike SSH, ping, Gui ?


Can you post LAN connection ifconfig IP address information.

When you remove and connected to wifi, can you post same information what is the IP address you have.




*** Rate All Helpful Responses ***

Screen Shot 2019-05-07 at 17.13.15.pngthere you go!


It is very weird. If I am connected to the wifi i no longer reach the Switch. ..


Ethernet from computer straight to switch

wifi, internal antenna

By the way I dont remove from ethernet. It is always connected. Its just the fact of turning on the wifi

This what is your problem, see th attachement, you have Wire and Wireless have same IP address,


You need to disable any one of them to work. ( not sure how your DHCP configured. ?)


*** Rate All Helpful Responses ***

Well. I have DHCP enabled on my wireless connection. And on my Ethernet port I have a static ip address to the switch default range. So

On the wifi is automatically created and the last number is x.x.x.95

So that's why I am getting a bit confused.

Anyway, what I will try is to maybe create a new IP address for the switch in another range to avoid conflict. Maybe that helps, but would be great to understand if it was possible to make it work like this

Is that the broadcast address that needed to be different?

Because the inet ip address is different. I will read to understand the differences between the inet and broadcast ip



on a side note, in theory it should be possible to use Wi-Fi and Ethernet on your iMac at the same time, even with IP addresses from the same range (unless you are using a really old MacOS version - which one do you have installed?). Just make sure both adapters use the same default gateway.

You could try and change the Service Order of your interfaces and put WiFi at the top (click on the Gear icon and select 'Set Service Order', then drag WiFi to the top of the list)...


I never had a problem before of using my ethernet port and WiFi port at the
same time with other networks.

This means I am using my WiFi for internet access and some duties, and the
ethernet in a LAN for other network environment.

It's only with the switch (which is new) and i am also learning how to work
with it

Hi just to let you know.



After configuring the switch to accordingly these setting i got it working.




It works with no problem now .. so there was something from those options that enabled and now its full on.


thank you

View solution in original post

even though this is the solution it would be great to understand why